[MPlayer-users] copy DVD, then compression, produces "jumpy " and pixelated avi?

jd1008 jd1008 at gmail.com
Sun Dec 28 01:15:27 CET 2014

On 12/27/2014 05:03 PM, Yang wrote:
> ok, I tried
> --dumpstream
> it's funny that on my laptop this produced correct result, but on another
> desktop, the exact same command still produced pixelated and jumpy video.
>   the file lengths are exactly the same, but contents are different. I tried
> the same command twice on the problematic desktop, both times it produced
> exactly the same file (binary equivalent byte by byte). I don't know why
> the two  boxes produced different files. both have libdvdread4 installed.
> both have the same ubuntu 14.04 and same version of mplayer/mencoder
> installed.....
It could be the 2 computers have different processing power, ram amount 
and graphics chipsets ....etc.
If you take the file from the box that is playing it badly to the box 
that plays well, how does it look?

> On Sat, Dec 27, 2014 at 7:42 AM, Reimar Döffinger <Reimar.Doeffinger at gmx.de>
> wrote:
>> On Sat, Dec 27, 2014 at 12:59:52AM -0800, Yang wrote:
>>> I copied down my DVD by -ovc copy , so that I have an exact high-quality
>>> copy of the original file.
>> A lot can, and often will, go wrong with -ovc copy.
>>> but the second batch of output produces very low quality, the images are
>>> highly pixelated, and the big pixels seem to jump quickly; the actual
>> file
>>> size being generated is much much smaller than the original DVD file.
>> but I
>>> did manage to get the bit rate up by using mencoder options, to about
>> 2000k
>>> bits/sec. but even at this high bitrate, the same problem still occurs.
>> For these use cases using bitrate is usually a bad idea. One-pass
>> bitrate encoding usually will result in occasionally bad bitrate not
>> matter how high you go.
>> You'll rather want "constant quality". That doesn't quite exist, but
>> the vqscale=... (for most codecs, 2 is a good value) or crf=... (for x264,
>> pick something around maybe 18) come close.
>>> that is wrong? I was thinking maybe on the second copy, libdvdcss is not
>>> automatically invoked so the result is garbled ? I checked libdvdread/css
>>> is installed correctly
>> CSS is not involved or required after the initial copy, decrypted is
>> decrypted, no point in doing that twice.
>> Probably your -ovc copy didn't produce a working file.
>> _______________________________________________
>> MPlayer-users mailing list
>> MPlayer-users at mplayerhq.hu
>> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list