[MPlayer-users] MPlayer hangs in slave mode on Windows

Anton Sviridenko anton at corp.bluecherry.net
Sat Dec 13 17:37:44 CET 2014

I am using r37337 build by Redxii from mplayerwin.sf.net. Exactly the
same build works perfectly when it is being run by SMPlayer.

But I observe this behavior - when I try to run mplayer from cmd.exe
and set -slave switch, mplayer starts, shows video window with first
frame and then hangs (Windows shows "not responding, cursors starts
rotating, etc). I found accidentally that if I press Enter in cmd.exe
console it starts playing until mouse click on video window. Then it
hangs again.I also tried to run mplayer in slave mode from Cygwin
console and it plays without hangs there.

I'm trying to use mplayer in slave mode  for playing videos inside
application I develop and it hangs probably due to same reason.

I tried to run mplayer with same switches as smplayer, to run it from
smplayer directory (in order to make sure it sees same config files) -
still hangs. Looked in smplayer source, did not find something
windows-specific in interaction with mplayer process.

Hangs are reproducible on Windows 7 32bit, Windows XP x64

Any ideas about reasons and how to fix it?

More information about the MPlayer-users mailing list