[MPlayer-users] MPlayer errors decoding captured streams

JW l-mphq at inter-sol.ca
Fri Nov 15 08:55:33 CET 2013

I tried the suggested workarounds
* with "-demuxer audio" mplayer still failed on the problem file
* with "-demuxer lavf" mplayer successfully decoded the file; I will use 
it in the future and see if I run into any other problem files.

Still, were the sample files I uploaded of any use in identifying the 
problem? Or is there another preferred method of submitting samples?


on 2013-11-03 4:51 PM JW said the following:
> Thanks. I've uploaded 2 samples (each about 21MB) to SendSpace:
> * mplayer-error.aac that produces the error: 
> http://www.sendspace.com/file/6zvxbg
> * mplayer-ok.aac that does not produce the error: 
> http://www.sendspace.com/file/l0itm2
> on 2013-11-03 1:23 PM Reimar Döffinger said the following:
>> On Sat, Nov 02, 2013 at 08:24:50PM -0700, JW wrote:
>>> I'm currently using "MPlayer sherpya-r36349+gb24f15c-4.6 (C)
>>> 2000-2013 MPlayer Team" under Win7 Pro x64.
>>> For at least the last year I've been saving streamed audio using
>>> mplayer, via
>>>      mplayer -playlist
>>> "http://playerservices.streamtheworld.com/pls/CBC_R1_VCR_H.pls"
>>> -cache 512 -dumpstream -dumpfile STREAMFILE.acc
>>> (Which I force to exit after a fixed period via TaskKill. Is there
>>> some other way to tell mplayer to stop saving after a fixed time?)
>> I don't know what that program does.
>> There is -endpos, but it works very badly for this use-case.
>> The way you are supposed to do is by either
>> 1) using -slave and sending a "quit" command - though I am not sure this
>> works with -dump*
>> 2) sending a SIGINT signal to the process
>> while both are also possible on Windows, to my knowledge they are a
>> huge pain to do unless you have e.g. cygwin installed
>>> For a long time this has been working reliably. However, recently
>>> the stream format has changed in some way that produces smaller
>>> saved stream files, without changing the format reported by
>>> MediaInfo. However, for about half (but not all) of the new,
>>> smaller, saved stream files MPlayer is unable to decode the stream
>>> that it has, itself, saved. Instead it reports an error.
>> A sample would be useful to allow us to fix it.
>>>      Playing STREAMFILE.aac.
>>>      libavformat version 55.9.100 (internal)
>>>      MPEG-PES file format detected.
>>>      MPEG: FATAL: EOF while searching for sequence header.
>>>      Video: Cannot read properties.
>> MPlayer seems to incorrectly think it is a MPEG-PES file.
>> -demuxer lavf or -demuxer audio will probably work around it.

More information about the MPlayer-users mailing list