[MPlayer-users] first frame green with directx vo using slave mode

Morris mo at avpresentations.com
Wed Nov 13 00:54:09 CET 2013


Using slave mode in windows 7 with the directx vo causes the first frame 
of a video to be green - AFTER - the first video plays.  In other words, 
the first video does not exhibit this, but all following videos do.  I 
am using  idle and fixed-vo to keep mplayer from exiting between 
videos.  Here is my command line:

-quiet -slave -idle -fixed-vo -vo directx ./media/big_buck_bunny_480p.av

This is using the   sherpya-r36475+g0bf8580-4.6   build.  I have found 
this to be true on all versions of mplayer I've tried in the last 6 
months to a year.  I had changed to direct3d and the gl vo quite some 
time ago, but some of the videos I have now don't play back smoothly 
enough with those video outputs, so I've gone back to directx which 
seems to be much faster than the others (i can send a benchmark if it 
will help).

I have disabled the aero desktop and gone to the basic themes under 
windows 7, but with no change in problem.  This is on a laptop with an 
i5 processor, 4 GB of memory and an nVideo nvs4200m video card. I've 
gotten the same results with other, similarly spec'd laptops.

I have tried setting the nVidia and also the intel chipset to be the 
priority graphics adapter in the operating system, but with no change in 
the problem.  I have played briefly with the colorkey setting in mplayer 
after seeing it mentioned in searches, but had no luck with it helping 
my issue.

I expect that this is related somehow to idle or fixed-vo since it 
doesn't happen with the first video, but don't really know.  Any ideas?



More information about the MPlayer-users mailing list