[MPlayer-users] mplayer update on FreeBSD ports

Antonio Olivares olivares14031 at yahoo.com
Sat Jan 28 04:55:44 CET 2012

--- On Fri, 1/27/12, Thomas Zander <thomas.e.zander at googlemail.com> wrote:

> From: Thomas Zander <thomas.e.zander at googlemail.com>
> Subject: Re: [MPlayer-users] mplayer update on FreeBSD ports
> To: "MPlayer usage questions, feature requests, bug reports" <mplayer-users at mplayerhq.hu>
> Cc: "Antonio Olivares" <olivares14031 at yahoo.com>
> Date: Friday, January 27, 2012, 7:08 AM
> On Sat, Jan 21, 2012 at 17:14,
> Antonio Olivares <olivares14031 at yahoo.com>
> wrote:
> > What exactly do you mean update the system?
> > It is up to date via ports.  Do you mean update to
> 9.0?
> No.
> It is probably best for you to first understand what FreeBSD
> is. There
> are two conceptually *different* things:
> 1) The base system (that is, kernel and some user land
> programs,
> shipped by the FreeBSD project)
> 2) The ports collection (user land programs from somewhere
> else)
> Important to know is that *both* are developed continuously,
> and you
> should update *both*.
> Please read this in order to get an idea of how it works:
> http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/current-stable.html
> Then upgrade your base system to whatever branch you want
> (any recent
> stable/8, stable/9 or current will do) and then your ports,
> including
> mplayer.
> Riggs

I have done this several times, but sometimes I fsck things up :(
and I prefer not to do this, unless I really have to.  At work I have an amd64 machine updated to 9.0-STABLE and an 8.2-RELEASE-p2 amd64 one, but If I try to buildworld and buildkernel, I run out of space, and I can't get anywhere :(  On those machines mplayer is running fine and I use mplayer from ports.  But on this machine, I removed the mplayer port

cd /usr/ports/multimedia/mplayer
make deinstall
cd ~

 and updated mplayer with svn update command.  I had then installed from source and had run mplayer svn.  I updated some ports and then left it at that.  I have a cron script that plays music so I can get up and go to work and it failed.  I checked and I got the lib-***.so error.  

I have updated svn and reconfigured, and recompiled and now I am in better shape.  

I will try to keep up mplayer updated via svn and in case I run into problems(with mplayer official freebsd ports), I will let you know.



More information about the MPlayer-users mailing list