[MPlayer-users] Help with 32bit mplayer

Deron Kazmaier deron at pagestream.org
Tue Jan 10 01:01:47 CET 2012

On 1/9/12 3:50 PM, Lucas wrote:
> Deron writes:
>> First, thanks for the hints from before. I've managed to compile the
>> 32bit mplayer with the decklink patch.
>> I'm running 11.04 64bit Ubuntu using a custom build 32bit version of
>> mplayer so I can play Apple ProRes files. That seems to be ok, but I
>> need to output to a Blackmagic DeckLink card.
>> I originally installed the 64bit DeckLink kernel modules using their
>> source and dkms and even compiled and ran some test applications and
>> wrote my own pass through code that works.
>> When I initially tried to use the 32bit mplayer, it complained that
>> "libDeckLinkAPI.so: cannot open shared object file: No such file or
>> directory" so I installed the 32 bit version of that link library.
>> But now when i try and play video to the decklink card, mplayer tells me:
>> [decklink] Could not find a Decklink device
> Hi Deron,
> I read your post and I try to do something similar.
> I try to get a stream of SDI Out of the DeckLink card.
> I tried a lot of technique but nothing works for now :(
> I wanted to know if you had succeeded?
> Sorry for my bad english.
> Sincerely,
> Lucas.

Hello Lucas,

About the time I wrote this, ProRes support was added into 
FFmpeg/mplayer, and the need to use 32 bit went completely away for me. 
I use 64bit mplayer, and output to DeckLink cards all the time.

What can I help with?


More information about the MPlayer-users mailing list