[MPlayer-users] ffmpeg H264 looses audio sync when playing HTTP stream

Rene Dohmen acidjunk at gmail.com
Wed Apr 18 21:23:17 CEST 2012

On Wed, Apr 18, 2012 at 7:44 PM, Andy Furniss <andyqos at ukfsn.org> wrote:

> Rene Dohmen wrote:
>> I tried to test it with -demuxer lavf and used the mplayer from homebrew
>> OSX for that:
>> Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
>> Unknown/missing audio format ->  no sound
>> ADecoder init failed :(
>> Requested audio codec family [a52] (afm=liba52) not available.
>> Enable it at compilation.
> Strange, does it work if you specify -ac ffac3 ?

I tried it again with an older build of mplayer for OSX found here

Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)

Indeed audio sync is a LOT better with the -demuxer lavf option :-)

It only needs a couple of seconds (around 5) when starting to get in sync

Thank you very much for the info :-)

More information about the MPlayer-users mailing list