[MPlayer-users] ERROR: mencoder may not support libx264.so

Thomas Boehm mplayer-users at lists.boehmi.net
Fri Nov 4 19:56:02 CET 2011

Nicolas George wrote:
> Some packaged versions of MPlayer are known to are broken.

As I wrote earlier I use the MOTU repository as suggested here


If I can't trust this one to be working, which one can I trust then? I
thought that the MOTU repository is the "official" and recommended one.

> Try compiling the
> latest SVN from from sources, after compiling a snapshot of x264 from the
> sources too.

I tried that, but it doesn't work as described in the documentation.
mplayer doesn't pick up the compiled x264 and it appears under disabled
optional drivers. Maybe it's the same reason why the binary from MOTU
doesn't work.

Here's what I'm doing

cd /usr/src
git clone git://git.videolan.org/x264.git
cd x264
make install
cd ..
svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer
cd mplayer

here it tells me that x264 is disabled and if I continue
mplayer/mencoder will be compiled without x264 support.

Next I tried ./configure --enable-x264

which throws a lot of libavcodec/libx264.c errors before giving up here

make[1]: *** [libavcodec/libx264.o] Error 1
make[1]: Leaving directory `/usr/src/mplayer/ffmpeg'
make: *** [ffmpeg/libavcodec/libavcodec.a] Error 2

Both files (libx264.o and libavcodec.a) don't exist in that directory.

Something is wrong here and I'm not a developer and be able to resolve
this. I'm just a normal user...

Thanks for reading

More information about the MPlayer-users mailing list