[MPlayer-users] configuration problem in mplayer

Steve Kelem steve at kelem.net
Fri Jun 24 09:16:43 CEST 2011

I checked out the latest subversion for mplayer on my Fedora 15 x86_64 system.
I ran configure.
When I run "make", I get the following error:
make -C ffmpeg/libavformat
make[1]: Entering directory `/local/usr/local/src/mplayer/ffmpeg/libavformat'
gcc -std=c99 -fomit-frame-pointer -pthread -g -Wdeclaration-after-statement -Wall -Wno-parentheses -Wno-switch -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wno-pointer-to-int-cast -O3 -fno-math-errno -fno-signed-zeros -fno-tree-vectorize -Werror=implicit-function-declaration -Werror=missing-prototypes -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -DHAVE_AV_CONFIG_H  -c -o 4xm.o 4xm.c
4xm.c:30:36: fatal error: libavutil/intreadwrite.h: No such file or directory
compilation terminated.
make[1]: *** [4xm.o] Error 1
make[1]: Leaving directory `/local/usr/local/src/mplayer/ffmpeg/libavformat'
make: *** [ffmpeg/libavformat/libavformat.a] Error 2

% gcc --version
gcc (GCC) 4.6.0 20110530 (Red Hat 4.6.0-9)

Any idea what's wrong?

More information about the MPlayer-users mailing list