[MPlayer-users] Playing an URL with special characters, charset problem

Arthur Helfstein Fragoso arthur at life.net.br
Tue Jan 11 02:03:58 CET 2011

On 01/11/2011 04:36 AM, Reimar Döffinger wrote:
> On Mon, Jan 10, 2011 at 08:02:59PM +0100, Reimar Döffinger wrote:
>> On Mon, Jan 10, 2011 at 11:58:41PM +0900, Arthur Helfstein Fragoso wrote:
>>> I tried to detail the problem as much as I could, so if it's not
>>> enough, please tell me what else I need to inform.
>> About the actual issue.
>> Because what you think is the issue isn't it.
>> The real issue is that Google once again implemented their own web server,
>> and time and again they prove to be completely incompetent at that.
>> Please compare:
>> -user-agent 'Mozilla'
>> returned file says "hao"
>> -user-agent 'Mozilla/5'
>> no sound at all
>> -user-agent 'Mozilla/5.0'
>> full file.
> Can't reproduce the "no sound" case any more, might have been a problem
> with my network connection.
> Let me merge my suggestion for a fix and my opinion on it in one statement: Use
> -user-agent 'Mozilla/666'
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users

Thank you very much Reimar,

You really solved the problem.

I tried and saw that any version equal or higher that 5 works

'Mozilla/7', 'Mozilla/8', 'Mozilla/9'

but I just was wondering why you suggested the number of the beast (666). :D

I googled it and I found: Mozilla/666.(6) libwww-perl/5.x

so, I guess you recommended it because I'm using perl.

It's not a big deal, I'm just curious, based on what do you suggest 

Thank you, I really appreciate your help.

Arthur Helfstein Fragoso
arthur at life.net.br

More information about the MPlayer-users mailing list