[MPlayer-users] Bug: fullscreen mode unusable with virtual X resolution

Alexander Shaduri ashaduri at gmail.com
Sat Mar 28 20:54:35 CET 2009

Hello all,

I have a problem with MPlayer SVN r29077 (it also exists in r28775,
but NOT in 28451).

The problem is that I can't get it to work correctly in fullscreen with
X virtual screen enabled.

My physical screen resolution is 1024x768, and the virtual is 1600x1200.
Also, nvidia's "NoTwinViewXineramaInfo" option in xorg.conf is enabled
(without it most of my window managers (window maker, kde3, kde4) are
really screwed up). Note that I don't use either Xinerama or Twinview.

I tried these combinations, and I can't find a usable configuration:

NoTwinViewXineramaInfo true, xineramascreen=-2:
    In fullscreen, mplayer shows the 1024x768 picture centered on a
    1600x1200 virtual area, making it almost unusable.
    Note that this used to worked correctly in r28451, the 1024x768
    picture being correctly displayed in the top left corner.

NoTwinViewXineramaInfo true, xineramascreen=-1 or 0:
    In fullscreen, mplayer shows 1600x1200 scaled picture (unusable
    with 1024x768 physical resolution).

NoTwinViewXineramaInfo false, xineramascreen any value:
    In fullscreen, mplayer shows correctly - 1024x768 picture in top-left corner.
    However, this mode is unusable because none of the common window
    managers work correctly with it (e.g. the menus appear only in 1024x768

I can provide any other information if needed.

Thanks in advance,

MPlayer configure args:
--prefix=/usr --confdir=/etc/mplayer --datadir=/usr/share/mplayer --libdir=/usr/lib --mandir=/u
sr/share/man --enable-runtime-cpudetection --enable-bl --enable-fbdev --enable-zr --enable-gui --enable-menu -
-language=all --enable-xvmc --with-xvmclib=XvMCW --enable-largefiles --enable-smb --enable-joystick --enable-r
adio --enable-radio-capture --disable-nemesi --disable-wii --enable-faad --enable-qtx --disable-arts --realcod

---------------------- System information

openSUSE Linux 10.3;
linux 2.6.28 #1 SMP PREEMPT Fri Jan 16 15:26:55 GST 2009 i686 athlon i386 GNU/Linux;

$ gcc -v
Using built-in specs.
Target: i586-suse-linux
Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --libexecdir=/usr/lib --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.2.1 --enable-ssp --disable-libssp --disable-libgcj --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --program-suffix=-4.2 --enable-version-specific-runtime-libs --without-system-libunwind --with-cpu=generic --host=i586-suse-linux
Thread model: posix
gcc version 4.2.1 (SUSE Linux)

GNU ld (GNU Binutils) (SUSE Linux)
GNU assembler (GNU Binutils) (SUSE Linux)

Window Maker 0.92.0

CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+

MSI NVidia GeForce 8600GT;
NVidia binary driver 180.41.

Creative Sound Blaster Live! 5.1 (with alsa drivers).

More information about the MPlayer-users mailing list