[MPlayer-users] Ignored heartbeat-cmd command

Vincenzo De Florio vincenzo.deflorio at gmail.com
Mon Mar 2 11:34:10 CET 2009

First of all, thank you very much!

Reimar Döffinger ha scritto:

> > On Sun, Mar 01, 2009 at 07:58:08PM +0100, Vincenzo De Florio wrote:
> >   
>> >> The above line renders myfile.avi, though the heartbeat command is
>> >> completely ignored. I tried other variants, e.g. via ~/.mplayer/config ,
>> >> but still with the same result. So I tried with
>> >>
>> >>     mplayer -heartbeat-cmd "echo try this > trythis.txt" myfile.avi
>> >>     
> >
> > Works just fine for me, only if playing video though.
> >   
You got me! Indeed I had specified "-novideo". Now the echo works, thank
you very much, though my other command does not:

    $ mplayer.exe -heartbeat-cmd "/usr/local/bin/sendHeartbeat.exe
    localhost"  Spiderman1.mkv
    MPlayer Sherpya-SVN-r28311-4.2.5 (C) 2000-2009 MPlayer Team
    CPU: Intel(R) Pentium(R) M processor 2.13GHz (Family: 6, Model: 13,
    Stepping: 8)
    SSE2 supported but disabled
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
    Compiled for x86 CPU with extensions: MMX MMX2 SSE
    getch2: 6 can't get number of input events  [disabling console input]

    Playing Spiderman1.mkv.
    [mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
    [mkv] Track ID 2: audio (A_MPEG/L3), -aid 0, -alang und
    [mkv] Will play video track 1.
    Matroska file format detected.
    VIDEO:  [avc1]  688x480  24bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
    Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
    AO: [dsound] 48000Hz 2ch s16le (2 bytes per sample)
    Starting playback...
    VDec: vo config request - 688 x 480 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.53:1 - prescaling to correct movie aspect.
    VO: [directx] 688x480 => 734x480 Planar YV12
    New_Face failed. Maybe the font path is wrong.
    Please supply the text font file (~/.mplayer/subfont.ttf).
    subtitle font: load_sub_face failed.
    New_Face failed. Maybe the font path is wrong.
    Please supply the text font file (~/.mplayer/subfont.ttf).
    subtitle font: load_sub_face failed.
    The system cannot find the path specified.
    The system cannot find the path specified. 0/  0 33%  7%  1.2% 6 0
    A:  37.6 V:  37.6 A-V: -0.005 ct:  0.003   0/  0 31%  7%  1.2% 6 0

On the other hand, the heartbeat-cmd string is a valid command:

    $ /usr/local/bin/sendHeartbeat.exe localhost
    InitLibrary_sender: sending data to 'PCINF55' (IP :
    sending OK

>From what above I understood that the problem was the path to the file,
so I tried first by copying the sendHeartbeat command to the current
working dir. As a result, no "The system cannot find the path
specified." anymore, but the command seemed not to have any visible
effect (no heartbeat was received by my watchdog). Any clue? Thanks in

> >   
>> >> P.S. I'm also sending this message to Mplayer-dev-eng .
>> >>     
> > It doesn't belong there.
> >   
Duly noted down, thanks.



More information about the MPlayer-users mailing list