[MPlayer-users] "'HAVE_LOG2' is not defined" make error in latest SVN

Richard Bromley rbromley256 at gmail.com
Sat Jul 11 01:36:57 CEST 2009

Hello. While compiling MPlayer SVN 29416, I get these errors:

In file included from libmpcodecs/vf_fspp.c:50:
./libavutil/internal.h:268:6: warning: "HAVE_LOG2" is not defined
In file included from libmpcodecs/vf_fspp.c:51:
./libavutil/internal.h:269: error: static declaration of 'log2'
follows non-static declaration
make: *** [libmpcodecs/vf_fspp.o] Error 1

This is the configuration I used:

Config files successfully generated by ./configure
--cc=i686-pc-linux-gnu-gcc --host-cc=i686-pc-linux-gnu-gcc
--prefix=/usr --confdir=/etc/mplayer --datadir=/usr/share/mplayer
--libdir=/usr/lib --enable-menu --enable-network --disable-fribidi
--disable-ftp --disable-lirc --disable-lircc --disable-joystick
--disable-cdparanoia --charset=UTF-8 --disable-tv-bsdbt848
--disable-ivtv --disable-tv --disable-tv-v4l1 --disable-tv-v4l2
--disable-radio --disable-radio-v4l2 --disable-radio-bsdbt848
--disable-dvb --disable-dvbhead --disable-tv-teletext --disable-v4l2
--disable-pvr --disable-liba52 --disable-liblzo --disable-speex
--disable-tga --disable-xanim --realcodecsdir=/opt/RealPlayer/codecs
--disable-directfb --disable-ggi --disable-md5sum --disable-aa
--disable-dga1 --disable-dga2 --disable-fbdev --disable-caca
--disable-vesa --disable-vdpau --disable-vidix --disable-vidix-pcidb
--disable-zr --disable-dxr3 --enable-gui --enable-xvmc
--with-xvmclib=XvMCW --disable-3dfx --disable-tdfxvid --disable-tdfxfb
--disable-arts --disable-jack --disable-ladspa --disable-nas
--disable-openal --disable-pulse --disable-altivec !

  Install prefix: /usr
  Data directory: /usr/share/mplayer
  Config direct.: /etc/mplayer

  Byte order: little-endian
  Optimizing for: native

    Messages/GUI: en
    Manual pages: en
    Documentation: en

  Enabled optional drivers:
    Input: dvdnav(internal) live555 cddb cdda libdvdcss(internal)
dvdread(internal) vcd smb network
    Codecs: libschroedinger libdirac x264 xvid libdv libamr_wb
libamr_nb libavcodec(internal) qtx real win32 faad2(internal) faac
musepack libdca libmpeg2(internal) liba52(internal) mp3lib(internal)
libtheora tremor(internal) twolame libmad gif
    Audio output: alsa esd oss sdl mpegpes(file)
    Video output: sdl gif89a pnm jpeg png mpegpes(file) opengl xvmc xv
x11 xover yuv4mpeg

  Disabled optional drivers:
    Input: vstream ftp pvr radio tv-teletext tv-v4l2 tv-v4l1 tv-dshow
tv nemesi dvb
    Codecs: xanim speex toolame liblzo
    Audio output: sun openal jack pulse nas arts v4l2 ivtv dxr2
    Video output: zr zr2 v4l2 ivtv dxr3 dxr2 vesa fbdev svga caca aa
ggi xmga mga xvidix winvidix cvidix 3dfx dga vdpau dfbmga directfb bl
md5sum tga xvr100 tdfx_vid wii s3fb tdfxfb

Last week, an earlier SVN revision of MPlayer compiled without errors
on the same machine (a Gentoo Linux system). Could I have some help in
resolving this? Thank you.

More information about the MPlayer-users mailing list