[MPlayer-users] Some LADSPA plugins combined with -vo gl:yuv=[2346]:cscale=[1-5]:lscale=[1-5] result in blank screen

Marcus Blumhagen marcus.blumhagen at web.de
Tue Jan 20 04:53:39 CET 2009


Please CC me in replies since I am not subscribed to the list.

I am using the latest SVN-Revision of MPlayer (dev-SVN-r28342-4.3.3)
with LADSPA support enabled. When I playback videos with the opengl
driver in combination with at least some LADSPA plugins, I cannot
enable cscale or lscale greater than 0 combined with yuv=[2346]. If I
would, mplayer will tell me this:

$ mplayer -vo gl:yuv=6:lscale=1:cscale=1 -af ladspa=/usr/lib/ladspa/sc4_1882.so:sc4:5e-1:15e-1:400:-30:20:10:24 video.avi

[gl] Error compiling fragment program, make sure your card supports
[gl]   GL_ARB_fragment_program (use glxinfo to check).
[gl]   Error message:
  line 2, column 220:  error: expected '}'
line 2, column 566:  error: expected '}'
line 2, column 912:  error: expected '}'
 at ,000977};A

and the screen will stay blank. /usr/lib/ladspa/sc4_1882.so belongs to
the swh-plugins package.

If I change either cscale and lscale to 0 or yuv to 0 or 1 the video
output works fine. The gl option nomanyfmts is no solution here.

If I don't use the LADSPA plugin at all, I can set arbitrary values
for yuv, cscale and lscale, i.e.:

$ mplayer -vo gl:yuv=6:lscale=1:cscale=1 video.avi

works just fine.

I tried some other LADSPA plugins to see whether this error only
happens with the above plugin. So I tried
ladspa=/usr/lib/ladspa/vcf.so:vcf_notch:0.5:45:0:0.01 which belongs to
vcf and it worked with the 1st example command line.

But ladspa=/usr/lib/ladspa/amp_1654.so:amp_gcia_oa:1 from the blop
package as another example results in the above error message again.

My graphics card is an NVIDIA GeForce 7800 GS AGP and I use the binary
NVIDIA driver in version 173.14.09. My system is an up to date Debian
Sid amd64. MPlayer was compiled using the debian/rules script supplied
in the svn repository with the following additional options:

--disable-pvr --disable-tv-teletext --disable-tv --disable-v4l2
--disable-dvb --disable-dvbhead --disable-ossaudio --disable-vidix
--disable-pnm --disable-fbdev --disable-tga

I believe this is a bug in mplayer, because loading an audio filter
should not affect the behavior of the video output driver IMHO.

Kind regards
Marcus Blumhagen

"Any intelligent fool can make things bigger, more complex, and more
violent. It takes a touch of genius -- and a lot of courage -- to move
in the opposite direction."
                                                      -- Albert Einstein

More information about the MPlayer-users mailing list