[MPlayer-users] compiling mplayer - no alsa device ?

Derek C derekmplayer at hssl.ie
Wed Jan 14 03:29:27 CET 2009

Hi all,

I'm still working on my H264 problem (mplayer with CoreAVC is giving much
better results than ffmpeg).

I'm concerned about my audio driver.

If I run "mplayer -ao help" I get the following: -

Available audio output drivers:
	oss	OSS/ioctl audio output
	mpegpes	DVB audio output
	v4l2	V4L2 MPEG Audio Decoder output
	null	Null audio output
	pcm	RAW PCM/WAVE file writer audio output

As you can see there is NO alsa driver listed.  I'd like alsa to be there!
 I tried "./configure --enable-alsa" (I know - shouldn't have to and
anyway configure --help tells me you can only disable, not enable, alsa).

Anyway - still no alsa driver.

I do have alsa sound in Ubuntu 8.10 (I think - at least alsamixer works
fine and /dev/dsp is there).

Do I need some extra alsa packages (or alsa-XXXXXX-dev stuff, etc)?

thanks for any help!


Derek C
In Ireland

More information about the MPlayer-users mailing list