[MPlayer-users] how to get vp6 codec to work?

Maik Meier mr.meyers at gmx.de
Sun May 18 15:47:20 CEST 2008

hi there,

I have a problem with watching an internet stream which uses vp6 codec. 
If I start mplayer with this stream(mplayer;stream.nsv), it automatically selects ffvp6 
(ffmpeg). And at first this seems to work, but only for a while. It 
crashes very often or is ever-changing the output resolution. mplayer says:

MPlayer interrupted by signal 11 in module: filter_video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in 
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We 
can't and
  won't help unless you provide this information when reporting a 
possible bug.
Uninit audio filters...
[libaf] Removing filter dummy
Uninit audio: faad
FAAD: Closing decoder!
Uninit video: ffmpeg
GNOME screensaver enabled
W: memblock.c: Memory pool destroyed but not all memory blocks freed! 1 
vo: uninit ...
bash: stream.nsv: command not found|

So, on my last notebook I tried the Windows codec in vp6vfw.dll. This 
worked much better (mplayer -vc vp6;stream.nsv).
But now on my new notebook this doesn't work anymore. I use Ubuntu Hardy 
64Bit and I downloaded the w64codecs.
If I type mplayer -vc help | grep vp6 it says:

|ffvp6       ffmpeg    working   FFmpeg VP6 decoder  [vp6]
ffvp6f      ffmpeg    working   FFmpeg VP6 Flash decoder  [vp6f]
vp6         vfwex     working   On2 VP6 Personal Codec  [vp6vfw.dll]|

But if I try to start the stream (mplayer -vc vp6 -v;stream.nsv) there is no video output. It says:

MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz (Family: 6, Model: 
15, Stepping: 11)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
get_path('codecs.conf') -> '/home/maik/.mplayer/codecs.conf'
Reading /home/maik/.mplayer/codecs.conf: Can't open 
'/home/maik/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': 
No such file or directory
Using built-in default codecs.conf.
Configuration: --enable-runtime-cpudetection --prefix=/usr 
--confdir=/etc/mplayer --mandir=/usr/share/man 
--win32codecsdir=/usr/lib/win32 --enable-largefiles 
--disable-libdvdcss-internal --enable-smb --enable-ftp 
--enable-cdparanoia --enable-radio --enable-lirc --enable-joystick 
--enable-xf86keysym --disable-tremor-internal --enable-liba52 
--enable-musepack --enable-speex --enable-libvorbis --enable-mad 
--enable-mp3lib --enable-theora --enable-libdv --enable-libmpeg2 
--enable-tv-v4l2 --enable-alsa --enable-ossaudio --enable-esd 
--enable-arts --enable-pulse --enable-nas --enable-xinerama 
--enable-menu --enable-xv --enable-vm --enable-gl --enable-xmga 
--enable-mga --enable-3dfx --enable-tdfxfb --enable-sdl --enable-aa 
--enable-caca --enable-dxr3 --enable-xvmc --with-xvmclib=XvMCW 
--enable-ggi --enable-fbdev --enable-freetype --enable-gif --enable-png 
--enable-jpeg --enable-liblzo --enable-fribidi --enable-ladspa 
--enable-libamr_nb --enable-libamr_wb --enable-faac --enable-gui 
CommandLine: '-vc' 'vp6' '-v' ''
get_path('font/font.desc') -> '/home/maik/.mplayer/font/font.desc'
font: can't open file: /home/maik/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
get_path('fonts') -> '/home/maik/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/home/maik/.mplayer/input.conf'
Can't open input config file /home/maik/.mplayer/input.conf: No such 
file or directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 81 binds
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote 
get_path('.conf') -> '/home/maik/.mplayer/.conf'

get_path('sub/') -> '/home/maik/.mplayer/sub/'
Filename for url is now
Filename for url is now
Resolving for AF_INET6...
Couldn't resolve name for AF_INET6:
Connecting to server[]: 8000...
protocol:           [ICY]
http minor version: [0]
uri:                [(null)]
method:             [(null)]
status code:        [200]
reason phrase:      [OK]
body size:          [1274]
 0 - icy-notice1:<BR>This stream requires <a 
 1 - icy-notice2:SHOUTcast Distributed Network Audio Server/Linux v1.9.7<BR>
 2 - icy-name:Demoscene.TV (HQ Realtime channel)
 3 - icy-genre:demoscene
 4 - icy-url:http://www.demoscene.tv
 5 - content-type:video/nsv
 6 - icy-pub:1
 7 - icy-metaint:8192
 8 - icy-br:600
Name   : Demoscene.TV (HQ Realtime channel)
Genre  : demoscene
Website: http://www.demoscene.tv
Public : yes
Bitrate: 600kbit/s
Cache size set to 320 KBytes
STREAM: [null]
STREAM: Description: http streaming
STREAM: Author: Bertrand, Albeau, Reimar Doeffinger, Arpi?
STREAM: Comment: plain http
CACHE_PRE_INIT: 0 [0] 0  pre:65536  eof:0  
Cache fill:  0.00% (0 bytes)   
ICY Info: 
Cache fill: 10.00% (32768 bytes)   
Checking for Nullsoft Streaming Video
Nullsoft Streaming Video file format detected.
demux_nsv: Header: NSVsVP61AAC
==> Found audio stream: 0
==> Found video stream: 0
demux_nsv: searching VP61 keyframe...
VIDEO:  [VP61]  640x480  24bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:36  fourcc:0x31365056  size:640x480  fps:25.00  ftime:=0.0400
get_path('sub/') -> '/home/maik/.mplayer/sub/'
X11 opening display: :0.0
vo: X11 color mask:  FFFFFF  (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1680x1050 with depth 24 and 32 bpp (":0.0" => local 
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Current fstype setting honours FULLSCREEN ABOVE BELOW X atoms
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
[xv common] Drawing no colorkey.
[xv common] Maximum source image dimensions: 2046x2046
Forced video codec: vp6
Requested video codec family [vp6] (vfm=vfwex) not available.
Enable it at compilation.
Cannot find codec matching selected -vo and video format 0x31365056.
Read DOCS/HTML/en/codecs.html!
Forced audio codec: mad
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.

AAC_PROBE: 4608 bytes

AAC_PROBE: ret 0
FAAD: Decoder init done (4608Bytes)!
FAAD: Negotiated samplerate: 140634409172224Hz  channels: 2
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 32000 Hz, 2 ch, s16le, 128.0 kbit/12.50% (ratio: 16000->128000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) 
Building audio filter chain for 32000Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 32000Hz/2ch/s16le
[dummy] Was reinitialized: 32000Hz/2ch/s16le
AO: [pulse] 32000Hz 2ch s16le (2 bytes per sample)
AO: Description: PulseAudio audio output
AO: Author: Lennart Poettering
Building audio filter chain for 32000Hz/2ch/s16le -> 32000Hz/2ch/s16le...
[dummy] Was reinitialized: 32000Hz/2ch/s16le
[dummy] Was reinitialized: 32000Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...|

I don't understand what I'm doing wrong? Has anyone an idea?
In the moment the only chance to watch the stream perfectly is to use 
winamp in a virtual machine, but I would prefer to use a native linux 


More information about the MPlayer-users mailing list