[MPlayer-users] MPlayer "seek bug"

Fulvio Peruggi fulvio.peruggi at alice.it
Sat Jun 14 00:58:37 CEST 2008

Hello people,

I'm completely new to this list so please don't blame me if I am not perfectly
compliant with usual rules...

I would like to report a bug that (I presume) affects MPlayer, although even
MEncoder is involved.

Brief description of the bug

Create an AVI movie by muxing a MPEG-4 (DivX) video file and an AC3 audio file
by means of MEncoder. Use MPlayer to play the movie and use the arrow keys to
jump forward or backward in the movie. Any time you press an arrow key the
video jumps where you want, but the audio restarts from the beginning of the

Long description of the bug

Sometimes I have a movie in two versions: good video and MP3 audio, bad video
and multichannel AC3 audio. So I create a new movie by muxing the good video
file and the AC3 audio file. (There are no synchronization problems if both
sources are PAL or both sources are NTSC; anyway I also was able to mux and
synchronize mixed sources, so forget about macroscopic synchronization
problems caused by a rookie). The resulting movie seems to be perfect under
any aspect, because it is played without problems by any software player
(except MPlayer) on a PC, as well as any external hardware player (universal
reader) I try.

Problems arise when I use MPlayer to display the movie. If I simply play the
movie, everything is fine: good display and correct audio output sent to the
six channels. However, if I try to skip forward or backward into the movie by
pressing the arrow keys on the keyboard, the video jumps to the correct
section, while the audio restarts from the very beginning of the movie! So.
e.g., I reach and watch the mid part of the movie, but at the same time I
hear the ouverture theme that should be played 30 minutes ago...

Further notes

This is not a problem concerning some very special file: I had the same result
when I tried to mux many different movies and AC3 soundtracks.

I discovered the bug several months ago on my usual platform (Pegasos computer
with G4 PowerPC processor and MorphOS operating system). But I report the bug
only now because I tried first to confirm it using MEncoder/MPlayer on a less
exotic platform. Recently I installed and used successfully MEncoder and
MPlayer on a standard PC under MS Windows. Given the same command line,
MEncoder version, and input files, the resulting movies on the Pegasos and on
the PC are equal (I compared their contents byte to byte). And even the
Windows version of MPlayer exhibits the same "seek bug" described above.

The "seek bug" does not occur if I try to rip the contents of one of my DVDs
saving its AC3 soundtrack: these files are displayed fine by MPlayer. The
"seek bug" only appears if I try to mux a video file and an audio file dumped
from existing AVI files.

This is a typical command line used for muxing:
 HardDisk:PathToTheProgram/MEncoder -oac lavc -ovc copy -lavcopts
acodec=ac3:abitrate=384 -force-avi-aspect 16/9 -ffourcc DX50 -noodml -o
"Final_movie_with_AC3_audio.avi" -audiofile "Dumped_AC3_soundtrack.ac3"

The problem arises with any version of MPlayer/MEncoder I tried, since
"MPlayer 0,91" up to "MPlayer 1.0rc2" and "MPlayer 1.0-SVN 2008.05.11" on the
Pegasos/Morphos platform (these are available on the homepage of Fabien
Coeurjoly, the programmer who creates MorphOS ports:
http://fabportnawak.free.fr/), and "MPlayer 1.0rc2" (the executable version
currently available for download on http://www.mplayerhq.hu/) on the
PC/Windows platform.

Thank you for your kind attention, and forgive me if I was boring...

Fulvio Peruggi

More information about the MPlayer-users mailing list