[MPlayer-users] mplayer on Solaris 10 x86 ?

Shane Ludwig sludwig at xo.com
Sat Feb 23 00:16:25 CET 2008

Responding to my own post here.  The gcc from sunfreeware is compiled using the
SUN-supplied assembler (/usr/ccs/bin/as) as opposed to the gnu-as.  This will
not work.  I therefore compiled my own gcc using gnu-as as specified here:
http://www.mplayerhq.hu/DOCS/HTML/en/unix.html (Section 12.3.1)

src/MPlayer-1.0rc2)$ which gcc

src/MPlayer-1.0rc2)$ /usr/local/bin/gcc -v
Reading specs from /usr/local/lib/gcc/i386-pc-solaris2.10/3.4.6/specs
Configured with: ../configure --with-as=gas --with-ld=/usr/ccs/bin/ld --enable-shared --enable-languages=c,c++,f77
Thread model: posix
gcc version 3.4.6

I then removed the mplayer directory, untarred the source fresh, reran
configure, and I still get the "illegal mnemonic" error that the SUN-supplied
as causes.

I then tried a make distclean and ran:

./configure --enable-gui --as=gas

Then ran make, but got the same errors:
 "<stdin>", line 12769 : Illegal mnemonic

So, I'm at a loss.  I even tried giving up on gcc and using SunStudio 12 but
that doesn't work at all.

I know there is a previous version of mplayer already compiled on Blastwave,
however, I don't like using the Blastwave packages as it requires installing a
whole duplicate set of all of the libraries, etc.  I've sent a note to the
maintainer of that package.  Hopefully he can provide some insight because at
this point I don't see how I can get this *&^% thing to compile.

On Feb 22, 2008 at 01:45 PM -0600, Shane Ludwig wrote:
> Reimar mentioned a different version compiler.  Has anyone had success with
> the gcc compiler from sunfreeware ?  It's at 3.4.6 as opposed to the SUN
> supplied one at 3.4.3.

Shane Ludwig            sludwig at xo.com
*   Every saint has a past and every sinner a future.  -- Oscar Wilde   *

More information about the MPlayer-users mailing list