[MPlayer-users] trying to pipe mencoder to ffmpeg2theora

Roman Haefeli reduzierer at yahoo.de
Thu May 17 10:44:02 CEST 2007

On Thu, 2007-05-17 at 09:46 +0200, Nico Sabbi wrote:
> Roman Haefeli wrote:
> > i tried what you suggested. i replaced the regular
> >files by named pipes (mkfifo stream.[wav|yuv]). but then, when both
> >commandline were started, on both ends the commands just waited and
> >obviously no data has passed. i tried every possible order to start the
> >commands. how is that supposed to work? do i need to create special
> >pipes?
> >
> >roman 
> >
> >
> >  
> >
> pipes work like short pipes :)
> you need 2 working processes to use them: one to write (mencoder &) and
> one to read (ffmpeg2theora) working at the same time

yeah, that is what i basically do. when i do 'cat mypipe' and in another
terminal 'echo foo > pipe', i see 'foo' in the first terminal. so, with
cat and echo piping is working as expexted, but when i do:

mplayer -vo yuv4mpeg:file=mypipe

and in another terminal

theora_encoder_example  mypipe

nothing happens. both commands just wait. can somebody confirm this?


Telefonate ohne weitere Kosten vom PC zum PC: http://messenger.yahoo.de

More information about the MPlayer-users mailing list