[MPlayer-users] mencoder not doing the business

Stuart Halliday stuarth at quantumsoft.co.uk
Mon May 14 20:16:11 CEST 2007

I believe Joey Parrish wrote this email section below:
> On 5/13/07, Stuart Halliday <stuarth at quantumsoft.co.uk> wrote:
>>> we are talking about *mplayer* here. If mplayer fails to decode the original
>>> avi file past 02:18 there'a an explanation for your short encode, otherwise
>>> the crystal ball must be brushed some more
>> When I play 'Mplayer for windows' (gmplayer on it then the sound is
>> there but there is no video playback at all - Black screen.
> Try running a new copy of mplayer/mencoder.  Yours is not current.

Odd that. I think it is.

I just popped over to the mplayer download page and there is
'MPlayer 1.0rc1 Windows'.

Which appears to be the same version as my current mplayer.exe. That is 
V0.0.9.0 in the Properties window.
Out of curiosity I tried a commandline version check and got

MPlayer 1.0rc1-3.4.2

Which is *exactly* the version I reported the fault with.

So how come the Mplayer developers don't update this '' in the .exe 

But I'm game for a laugh and tried the latest one on the web page just in 
case I'm wrong.
But no, its still doesn't encode the full movie. Just the first 138secs.

Any clues why it can't do the job?

Out of further curiosity I encoded the raw video to divx and resized it to 
720x576 using virtualdub. It did it perfectly. But virtualdub doesn't output 

I happen to have several 720x576 avi raw files and this mencoder also 
managed fine to encode to mp2. So maybe its the frame width and height that 
it doesn't like?

Stuart Halliday

More information about the MPlayer-users mailing list