[MPlayer-users] mplayer plays commentary on movie dvd and not the movie

Arvind Marathe arvind at mbu.iisc.ernet.in
Fri May 11 07:46:06 CEST 2007

> On 5/10/07, Joey Parrish <joey.parrish at gmail.com> wrote:
>> On 5/10/07, Arvind Marathe <arvind at mbu.iisc.ernet.in> wrote:
>> > Hi all,
>> > i have several movie dvd's which also have commentaries on the movie and
>> lot of
>> > other stuff apart from the movie itself. When i just give
>> > mplayer dvd://1
>> > it starts playing the commentary on the movie and not the movie. In some
>> cases,
>> > the title 1 started the commentary but
>> > mplayer dvd://2
>> > started playing the actual movie. However there are other dvd's with
>> only one
>> > title and mplayer tends to play only the commentary. I have also tried
>> the
>> > 'dvdnav' and all other options that come with it, with no result. I have
>> heard
>> > there is no dvd menu support for mplayer, so is there any indirect way
>> to select
>> > "Play The Movie" option from the dvd menu and not "Commentary" option?
>> Or
>> > mplayer cannot do that?
> If you'll do the following this should prevent the stupid commentary from
> coming on:
> mplayer dvd://1 -alang en
> Or whatever language you prefer. It is annoying to hear that commentary when
> you want to hear the movie. But the above works for me.
> Hank
> mplayer dvd://1 -aid 129
>> Use mplayer dvd://1 -v and scroll to the top to see available audio ids.
>> --Joey

Thanks Joey and Henry, it works partially. For example, one of the movies i have
is italian and i would rather prefer to hear the movie in italian with english
subtitles. So if i give
mplayer dvd://1 -alang it -slang en
the movie starts playing and not the commentary, however there are simply no
subtitles displayed. The -v option shows english as the subtitle stream and vlc
displays the english subtitle stream, so it is available. I tried toggling with
'v' or 'j' options, it toggles between 'subtitles enabled' and 'subtitles
disabled', but in enabled mode, simply does not display any subtitles. I tried
with '-sid 0' etc but still it does not work. Why is this happening and how to
get rid of it?


More information about the MPlayer-users mailing list