[MPlayer-users] Mencoder 20060608 cannot play ".rm"

hob4bit - hob4bit at hotmail.com
Fri Jun 9 13:47:21 CEST 2006

I had a working MPlayer-1.0pre7try2 installation for some time.  I recently 
upgraded to
MPlayer-20060608 to get Xvid 1.1.0 and Tivo support. Between the two events 
must have renamed "/usr/local/lib/codecs" back to "/usr/local/lib/win32" to 
fix Xine
problems. Why can't MPlayer look at all locations for codecs:


My problem is solved by just renaming back. For Xine I reconfigure it to 
read from
"/usr/local/lib/codecs". For Ubuntu 6.06 I fixed problems by linking:

ln -s /usr/local/lib/codecs /usr/lib/win32

All these different locations of "codecs" is very confusing. It should be 
Thanks for your help. I have just one remaining problem and that is why
MPlayer encoded XivD movies cannot be played in Windows Media Player
while having XviD 1.1 codec for Windows installed. I have some useful
advice but nothing seems to work.

I suspect that MPlayer encoded XviD fiels do not stick to the Microsoft AVI
standard. MPlayer should not use extensiosn to the AVI format as its a
Microsoft standard.

I am going to try "transcode" if all fails as I heard that it makes "XviD" 
that work
in WMP.

>From: Dominik 'Rathann' Mierzejewski <dominik at rangers.eu.org>
>Reply-To: "MPlayer usage questions, feature requests,  bug reports" 
><mplayer-users at mplayerhq.hu>
>To: mplayer-users at mplayerhq.hu
>Subject: Re: [MPlayer-users] Mencoder 20060608 cannot play ".rm"
>Date: Fri, 9 Jun 2006 10:48:40 +0200
>On Friday, 09 June 2006 at 07:50, - - wrote:
> > >On Thursday, 08 June 2006 at 15:56, - - wrote:
> > >> Dear Folks,
> > >>
> > >> Hello, I have previously "MPlayer 1.0pre7try" which had problems
> > >> with reading ".tivo" files. I upgraded to the latest 20060608
> > >> version and now it does not play ".rm" files. Both versions
> > >> were compiled from source using Knoppix 4.0.2.
> > >>
> > >> Does anybody know what is wrong? I have noticed that Ubuntu 6.06's
> > >> MPlayer also have this problem. Has ".rm" support but dropped or
> > >> do I know need some codecs?
> > >
> > >We need samples. If you can, please do regression testing:
> > >http://www.mplayerhq.hu/DOCS/HTML/en/bugreports_regression_test.html
> > >and find out when it got broken.
> >
> > Hello, the URL you gave me does not work.
>Use www1 instead of www. One of the mirrors is missing a piece of 
> > I rebuild my old
> > "mplayer-1.0pre7try2"
> > source. Problem still occurs. My system may be screwed up. My error is 
> > follows.
> >
> > I put my codecs at "/usr/local/lib/win32". I renamed it to
> > "/usr/local/lib/codecs" and everything worked again. I think I renamed
> > because of the need of "Xine". I will stick a symbolic link.
> >
> > I feel very stupid for my mistake. Thanks for your help.
>I'm confused. Do you still have the problem or was it because of the wrong
>location and is now resolved?
> > ====
> >
> > VDecoder init failed :(
> > Opening video decoder: [realvid] RealVideo decoder
> > Win32 LoadLibrary failed to load: drv43260.dll,
> > /usr/local/lib/codecs/drv43260.dll, /usr/lib/win32/drv43260.dll,
> > /usr/local/lib/win32/drv43260.dll
> > Error loading dll
> > ERROR: Could not open required DirectShow codec drv43260.dll.
>Apparently it cannot find the required file.
>MPlayer developer and RPMs maintainer: http://rpm.greysector.net/mplayer/
>There should be a science of discontent. People need hard times and
>oppression to develop psychic muscles.
>	-- from "Collected Sayings of Muad'Dib" by the Princess Irulan
>MPlayer-users mailing list
>MPlayer-users at mplayerhq.hu

Be the first to hear what's new at MSN - sign up to our free newsletters! 

More information about the MPlayer-users mailing list