[MPlayer-users] Problem playing DTS Audio CD

Barak Zalstein barak.zalstein at gmail.com
Fri Jun 2 04:00:37 CEST 2006

2006/6/1, Vladimir Mosgalin <mosgalin at vm10124.spb.edu>:
> Hi Barak Zalstein!
> On 2006.05.31 at 20:58:01 +0300, Barak Zalstein wrote next:
> > Adding this switch also fails:
> > Playing cdda://1.
> > Found Audio CD with 7 tracks
> Why can't you use search?? It has been discussed many times.
> cdda://1 -rawaudio format=0x2001
> Yes, such forcing isn't a proper way, on the other hand it works ever
> since dts support was introduced.
I used that switch with MPlayer-1.0pre7try2 and it works ok, almost - the
sound still pauses every second. when I use "-ao alsa" or "-ao oss" the time
between each pause is different (I am able to play and save output of dts
wav files with dtsdec executable, but couldn't find a way for generating a
non-downsampled usable output).
Using "-ao pcm" with mplayer creates an output file which is listenable but
mplayer crashes with signal 11 after a while  (and I  think that the output
is downmixed as well as I hear no sound on left speakers while
6_channels_id.wav test plays ok)
When using mplayer_20060519 and ffmpeg_20060519 with that switch, dts is not
found in libavcodec and hwac3 is tried instead. This problem is mentioned in
but the suggested solution of installing libdca did not help.
(I tried libdca-0.0.2.tar.gz<http://download.videolan.org/pub/videolan/libdca/0.0.2/libdca-0.0.2.tar.gz>)


More information about the MPlayer-users mailing list