[MPlayer-users] Problems with XV

Kevin DeKorte kdekorte at yahoo.com
Sun Aug 13 02:36:08 CEST 2006

Hash: SHA1

I think I have a problem with xv support in current SVN.

When I run mplayer with -vo xv from a terminal everything works fine.
But when I run mplayer -vo xv -wid (something) mplayer will crash with
an error in decode video. This happens pretty regularly in
mplayerplug-in. If I change the vo to x11 then everything is fine. I
know this used to work in pre7 so perhaps something has changed in xv
support. Also this problem has been seen in i810 and nvidia chipsets so
I don't think it is a driver issue. Also it does not seem to happen
every single time. Maybe the window that it is being drawn to has been
initialized, but is not completed.

mplayer -wid 0x180206f -vf scale=500:-3 -vo xv -ao esd -osdlevel 0
- -nojoystick -noconsolecontrols -cookies -slave -user-agent NSPlayer
- -nomouseinput -nocache /tmp/mplaypXbluJ
 MPlayer dev-SVN-r19351-4.1.1 (C) 2000-2006 MPlayer Team

 CPU: Intel(R) Pentium(R) M processor 1.73GHz (Family: 6, Model: 13,
Stepping: 8)

 CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
 Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
 Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
 Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system
startup scripts.
 Setting up LIRC support...
 mplayer: could not connect to socket
 mplayer: No such file or directory
 Failed to open LIRC support.
 You will not be able to use your remote control.

 Playing /tmp/mplaypXbluJ.
 Quicktime/MOV file format detected.
 VIDEO:  [cvid]  200x150  24bpp  6.452 fps    0.0 kbps ( 0.0 kbyte/s)
 Opening video filter: [scale w=500 h=-3]

 Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
 Selected video codec: [ffcvid] vfm: ffmpeg (Cinepak Video (native codec))


 Opening audio decoder: [pcm] Uncompressed PCM audio decoder
 AUDIO: 11114 Hz, 1 ch, u8, 88.9 kbit/100.00% (ratio: 11114->11114)
 Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)

 [AO ESD] latency: [server: 1.12s, net: 0.00s] (adjust 1.12s)
 AO: [esd] 44100Hz 1ch u8 (1 bytes per sample)
 Starting playback...

Setting file mode back to blocking
 VDec: vo config request - 200 x 150 (preferred colorspace: Planar YV12)
 VDec: using Planar YV12 as output csp (no 0)
 Movie-Aspect is undefined - no prescaling applied.
 SwScaler: reducing / aligning filtersize 5 -> 4
 SwScaler: reducing / aligning filtersize 5 -> 4
 SwScaler: reducing / aligning filtersize 5 -> 4
 SwScaler: reducing / aligning filtersize 5 -> 4

 SwScaler: BICUBIC scaler, from 0x32315659 (21VY) to 0x32315659 (21VY)
using MMX2

 SwScaler: using 4-tap MMX scaler for horizontal luminance scaling
 SwScaler: using 4-tap MMX scaler for horizontal chrominance scaling
 SwScaler: using n-tap MMX scaler for vertical scaling (YV12 like)
 SwScaler: 200x150 -> 500x376
 VO: [xv] 500x376 => 501x376 Planar YV12

 MPlayer interrupted by signal 8 in module: decode_video


- --
Get my public GnuPG key from
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the MPlayer-users mailing list