[MPlayer-users] Re: RTSP/1.0 400 Bad Request

Reza Roboubi reza at parvan.net
Fri Apr 14 23:25:22 CEST 2006

The Wanderer wrote:
> Reza Roboubi wrote:
>> Reza Roboubi wrote:
>>> Guillaume POIRIER wrote:
>>>> Does it work with CVS version? If you haven't tried, please do.
>>> Yes, it happens with CVS as well.
>> So... I also checked with the Ubuntu mplayer package, which like
>> MPlayer-1.0pre7try plays the older video just fine.  But on this
>> newer video, CVS, MPlayer-1.0pre7try, and Ubuntu, are all giving the
>> exact same error:
> I've kept silent up to now, but I'd just like to say here: there is no
> such MPlayer version as "1.0pre7try". There is "1.0pre6", "1.0pre7",
> "1.0pre7try2" - but no "1.0pre7try". The fact that you are so
> consistently reporting that version number means that either you are
> leaving the 2 out (perhaps under the impression that it's not
> important), or whoever packaged your MPlayer did so in a more-or-less
> broken fashion so that it gives an incorrect version number; regardless,
> we have no way of knowing for sure what version you're actually talking
> about.

I'm aware of the Mplayer guideline, which says that no support is available
for "third party" packagings.

This is only a typo.  My mistake.  And we kept pressing "reply" and quoting it.
Thanks so much for pointing it out.

Yes, my version is certainly MPlayer-1.0pre7try2, which I have compiled myself
on an Ubuntu Breezy distribution.

This is the full output:
reza at Reza:~/tmp/main$ ~/tmp/usr/bin/mplayer -vo gl2 "rtsp://rm.z1.mii-streaming.net/media/pbs/quicktime_real/virage/newshour/pbsnh070803_220k.rm?start=00:26:46.17&end=00:35:52.08"
MPlayer 1.0pre7try2-3.4.5 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Failed to open /dev/rtc: Device or resource busy (it should be readable by the user.)
Playing rtsp://rm.z1.mii-streaming.net/media/pbs/quicktime_real/virage/newshour/pbsnh070803_220k.rm?start=00:26:46.17&end=00:35:52.08.
Resolving rm.z1.mii-streaming.net for AF_INET6...
Couldn't resolve name for AF_INET6: rm.z1.mii-streaming.net
Resolving rm.z1.mii-streaming.net for AF_INET...
Connecting to server rm.z1.mii-streaming.net[]:554 ...
librtsp: server responds: 'RTSP/1.0 400 Bad Request'
librtsp: server responds: 'RTSP/1.0 400 Bad Request'
Cache size set to 640 KBytes
Connected to server: rm.z1.mii-streaming.net
Cache fill:  0.00% (0 bytes)
Snap!  It freezes right there.

But this other stream works great:
~/tmp/usr/bin/mplayer -vo gl2 "rtsp://rm.z1.mii-streaming.net/media/pbs/quicktime_real/virage/newshour/pbsnh030201_220k.rm?start=00:33:25.00&end=00:43:23.29"

>> librtsp: server responds: 'RTSP/1.0 400 Bad Request'
> Random curiosity: what version of librtsp is this? Since it's being used
> at some point in the chain, is there a possibility that there's a
> protocol incompatibility involved somewhere? (I don't think I've ever
> even heard of librtsp outside of this thread... it certainly doesn't
> seem to be available through Debian.)

You know, I honestly have no idea where it is coming from?

I've even done:
# /etc/cron.monthly/slocate
# slocate rtsp |less

And nothing interesting shows up (output provided upon request.)

Can you help me figure out where this message is coming from?


More information about the MPlayer-users mailing list