[MPlayer-users] How to tell how far through you are

Kichigai Mentat kichigai at comcast.net
Sun Apr 2 22:31:00 CEST 2006

Hash: SHA1

On Apr 2, 2006, at 15.03, Raphael wrote:

> Kichigai Mentat wrote:


>>>> Odd, because I thought that the progress meter worked fine.  
>>>> Could you upload a sample file for us to work from?
>>> http://www.lesshaste.plus.com/test.dump
>> Well, I looked at your file, and I discovered some interesting  
>> things about it. First off: the sample you dumped was indeed a  
>> RealMedia muxed file, not just a stream dump of the audio.  
>> However, it's done weirdly. MPlayer will play it, but, as you  
>> said, seeking is totally b0rk'd. It wouldn't give me the proper  
>> seek in seconds, but I was able to get the percentage to work with  
>> -idx (not what you're looking for, but it gives us something to  
>> start from).
>> However, when I tried playing it in VLC, it simply started to fill  
>> up the playlist with gibberish, and spat back enough errors to  
>> crash the player. I took a stab at it with the RealPlayer (yeah, I  
>> have that...) but it refused to play the file. It gave a nod to  
>> RealAudio 8, but that's about it. ffplay just locks up when I try  
>> to play it.
>> I also tried my solution: remux it with Matroska. MKVMerge  
>> recognizes the RealMedia muxing, but it can't find an audio  
>> stream. Try as I might, I can't get anything out of it. I also  
>> tried dumping the raw audio data to a file using -dumpaudio. The  
>> dump is successful, but the binary data is worthless. MPlayer/ 
>> MEncoder don't recognize it, and neither does MKVMerge.
>> How did you come across this file? Is it a download? A stream  
>> dump? I think that the problem isn't completely with MPlayer any  
>> more, but also with the source. Do YOU have any other players that  
>> recognize the file? As an OS X user, I have a different library of  
>> tools available (No win32 codecs...) so perhaps you can dig up  
>> something I can't.
> The file was created with
> mplayer -dumpstream rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/ 
> radio1/live/r1_dsat_g2.ra

Well, there's part of the problem. RealNetworks likes to be very  
possessive with their media. Also, this is a progressive stream. If  
this were a video, it'd probable be in a MPEG-2 Transport Stream. It  
was never meant to be seeked (well, I don't know another word for  
it... sought?) through. The stream was just never meant for this.

> I did manage to convert it to mp3 by making a fifo and doing
> mplayer stream.dump -ao pcm:file=audio.fifo:fast
> and then using lame on that fifo (strangely it encoded only the  
> first 3 hours but that is a different matter probably related to  
> fifos)
Version: GnuPG v1.4.1 (Darwin)


More information about the MPlayer-users mailing list