[MPlayer-users] Using mplayer with Audible Words Codec

Michael Ihde mike.ihde at gmail.com
Mon May 9 20:32:57 CEST 2005

I was wondering if anyone has tried to use the Audible Words Codec
(via DirectShow plugin) on mplayer?  I've tried to get it working
myself, but things aren't working....

First I tried simply opening the .aa file via

$ mplayer filename.aa

in the output I see an error "Cannot find codec for audio format
0x56444152", and then I see a video of a bunch of random colored

Then I edit codecs.conf with this information:

audiocodec audible
  info "Audible Book Format"
  status untested
  format 0x56444152
  driver dshow
  dll "awrdscdc.ax"
  guid 0x083863f1, 0x70de, 0x11d0, 0xbd, 0x40, 0x00, 0xa0, 0xc9, 0x11,
0xce, 0x86

and then I proceeded to copy awrdscdc.ax to my /usr/lib/win32
directory, which contains the other files installed by w32codecs.  Now
when I run I get this (abbreviated) output:

$ mplayer filename.aa -novideo
Playing filename.aa.
Cache fill: 0.00% (0 bytes)   RAWDV file format detected
Trying to force audio codec driver libmad...
Opening audio decoder: [dshow] Win32/DirectShow decoders

MPlayer interrupted by signal 11 in module: init_audio_codec

Any ideas?

More information about the MPlayer-users mailing list