[MPlayer-users] No picture when playing VSoft's H.264 demo clips

Loren Merritt lorenm at u.washington.edu
Tue May 3 10:07:18 CEST 2005

On Tue, 3 May 2005, RC wrote:

> On Fri, 29 Apr 2005 22:36:22 +0200
> Haakon Riiser <haakon.riiser at fys.uio.no> wrote:
>> Just tried some of the demo clips available at
>> <http://www.vsofts.com/h264/videoclips.html> and none of them
>> produced a picture, just a black display.  Should it have worked?
> Doesn't work for me, so I'd say no...
> Looking at their site, the downloadable codec seems to be time-limited,
> so maybe the DLL in the codecs pack has stopped working?

Those clips are H.264, so shouldn't require a binary codec.
I tried just adding VSSH to the 4cc list of ffh264, but no go.
Then I demuxed the videos (mencoder -ovc copy -of rawvideo), and ffh264 
did play those results, with some complaints about "Unknown NAL code: 0".
(JM 9.5 complained similarly. The spec says NAL code 0 is legal but 
undefined.) Combine that with the fact that half of the AVI-frames have 
size 4 bytes, and I'm betting that VSSH uses DivX-like packed B-frames.

In short: the clips are valid and playable insofar as you accept 
container-in-a-container. Do we want to support that, or just tell people 
to remux?

--Loren Merritt

More information about the MPlayer-users mailing list