[MPlayer-users] dfbmga problems (esp. loss of A/V sync with fieldparity)

Tony Houghton h at realh.co.uk
Thu Jan 20 18:49:41 CET 2005

I recently installed a Matrox G450 to play video to my TV with the
dfbmga output driver. The main reason I chose this card was because of
the availability of the fieldparity option, but there are a few problems
with it.

When using the fieldparity option (-v dfbmga:fieldparity=top) I
gradually lose A/V sync with the picture being delayed behind the sound.
This is mainly on interlaced programs recorded from my DVB-T card with
VDR, but I had the same symptoms on a non-interlaced AVI too (most AVIs
seem OK). The files start off in sync, but gradually get worse. If I
seek back a few seconds (eg with left arrow) the sync gets corrected,
but gradually the delay builds up again. I can't seem to correct it with
the A/V delay controls either, it's as if adding/subtracting a delay
causes a shift in the original delay I'm trying to correct for.

I can solve the problem by using the framedrop option, but I can see the
frames being dropped quite often, so this is less than ideal. Is there a
better cure? I've also tried autosync, but that didn't seem to help. I
also tried -ao oss instead of alsa, including using OSS kernel modules
instead of ALSA, but that didn't help either. I've just remembered one
of MPlayer's error messages suggests using -ao sdl, but I haven't got
around to trying that yet. Might that help?

Using dvb://... as an input, things are worse. With framedrop the sync
doesn't build up, but always seems to be out by a couple of tenths or
so. It also seems to have trouble playing some streams, with the error
about my system being too slow (even though the CPU load is generally
only 40% while playing DVB). It's been a while since I played with tzap
and getting mplayer to play the output of that, but I don't think that
had similar problems.

The other main problem is that if I use "no-vt" in directfbrc, and the
noinput sub-option to -vo dfbmga [1], this seems to cause MPlayer to
hang with a black screen, either immediately or after a few seconds.

[1] So that I can run MPlayer remotely without root access.

TH * http://www.realh.co.uk

More information about the MPlayer-users mailing list