[MPlayer-users] Trouble with radio audio streams encoded in WMA9 (WMAv3)

Anders Lind lists at iolife.dk
Sun Jan 9 18:58:09 CET 2005


A lot of Danes have the following problem:

When listening to the national radio station in Denmark ( DR - Danmarks
Radio ), you have to use WMA9 (WMAv3 as I understand the name of the
codec is called.)

However, I guess a lot of other people could be getting into the same
trouble in the future as well when more stations start to use WMA9

The problem is that unless you use Microsofts Media Player 9+ you will
only hear the stream in 20 Kbit/s even though you choose a stream of
either 64Kbps, 32Kbps or 20 Kbps.

Danmarks Radio knows of this problem, but they do not know, what to do
about the problem as it seems when I read threads from other people on
the net. So that's kind of bad.

Please visit for the links:

So here is what I have tried to make it work, but without any luck:

1. I obviously tried to just run several of the links direct (Remember
to get the direct links from within the .asx files) as well from the net
player, ( In the upper left corner of the DR home page under 'HØR
RADIO') , with the mplayer plug-in.

But the plug-in seems to be rather unstable, at least with WMA9. I
didn't manage to get the stream through the plug-in but only via mplayer
direct. But a friend of mine could use the plug-in, however it sounded
like 20 Kbps.

2. So then I tried to fiddle with /etc/mplayer/codecs.conf

I deactivated ffwmav2 (I don't think that I deactivated any other codec)
and put in a 'format 0x161' into the description of 'audiocodec wma9dmo'
since audio format 0x161 was requested by mplayer, when I deactivated
the 0x161 lines from other codecs supporting playing wma.

The result was, that I only got 20 Kbps with Microsofts own

3. Finally i tried as well with Kaffeine (That utilizes Xine as I
understand it) but also here the result was 20 Kbps, but I understand
that Xine and MPlayer share code (for good obvious reasons :) ), so that
might be the reason???

4. And strangely it works with Microsoft's own media player from version
9 and up.

So the question is where the problem lies - beside that Danmarks Radio
chose WMA9 (WMAv3) of cause :)

Is it a known problem? Is there a known solution that you know of?

Kind regards

Anders Lind, Denmark

PS I am running Debian Sarge and MPlayer 1.0pre6-3.3.4 with the w32
plug-ins using the available Debian packages as described here:
I've also tried other older versions in the past that had the same

Another friend of mine is running the newest Fedora (as I understand it)
using the rpm-version and he has the same problem.

More information about the MPlayer-users mailing list