[MPlayer-users] Re: [20/5] problems compiling MPlayer-1.0pre7 on Solaris 9 with gcc 3.4.2

Craig Dewick cdewick at lios.apana.org.au
Tue Aug 23 04:51:32 CEST 2005

> Message: 5
> Date: Fri, 19 Aug 2005 15:19:10 -0400
> From: Rich Felker <dalias at aerifal.cx>
> Subject: Re: [MPlayer-users] problems compiling MPlayer-1.0pre7 on
> 	Solaris 9	with gcc 3.4.2
> To: "MPlayer usage questions, feature requests,	bug reports"
> 	<mplayer-users at mplayerhq.hu>
> Message-ID: <20050819191910.GS326 at brightrain.aerifal.cx>
> Content-Type: text/plain; charset=us-ascii
> On Sat, Aug 20, 2005 at 04:32:20AM +1000, Craig Dewick wrote:
> >
> > Hi everyone,
> >
> > I've configured the MPlayer-1.0pre7 source (Sun Ultra 60, Solaris 9, gcc
> > compiler) using this set of options to the configure script:
> >
> > sh ./configure --with-install=/usr/ucb/install --enable-menu --enable-gui \
> > 	--with-xanimlibdir=/usr/local/xanim --cc=gcc --host-cc=gcc \
> > 	--enable-runtime-cpudetection --enable-shared-pp
> --enable-shared-pp is known to be broken and not supported

Ok I removed that from the configure options and it's compiled seemingly
ok except for this error message:

---- start ----

gcc -I../libvo -I../../libvo -O4 -mcpu=v9 -pipe -ffast-math
-fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
-I/usr/local/include/gtk-1.2 -I/usr/local/include/glib-1.2
-I/usr/local/lib/glib/include -I/usr/openwin/include -I.
-I/usr/local/include/freetype2 -I/usr/local/include
-I/usr/local/include/gtk-1.2 -I/usr/local/include/glib-1.2
-I/usr/local/lib/glib/include -I/usr/openwin/include
-I/usr/local/include/SDL -D_REENTRANT -o mencoder mencoder.o
mp_msg-mencoder.o cpudetect.o codec-cfg.o spudec.o playtree.o
playtreeparser.o asxparser.o vobsub.o subreader.o sub_cc.o find_sub.o
m_config.o m_option.o parser-cfg.o m_struct.o edl.o unrarlib.o divx4_vbr.o
libvo/aclib.o libvo/osd.o libvo/sub.o libvo/font_load.o
libvo/font_load_ft.o xvid_vbr.o parser-mecmd.o libmpcodecs/libmpencoders.a
-lmp3lame libmpcodecs/libmpcodecs.a libaf/libaf.a libmpdemux/libmpdemux.a
input/libinput.a postproc/libswscale.a osdep/libosdep.a -Llibmpdvdkit2
-lmpdvdkit libavcodec/libavcodec.a libavformat/libavformat.a -lmp3lame
-lpng -lz -lz -ljpeg -L/usr/local/lib -R/usr/local/lib -lfreetype -lz
-ltermcap -lsocket -lnsl libfaad2/libfaad2.a mp3lib/libMP3.a
liba52/liba52.a libmpeg2/libmpeg2.a tremor/libvorbisidec.a
-L/opt/SUNWmlib/lib -R/opt/SUNWmlib/lib -lmlib -lposix4 -lkstat -lpthread
-ldl -rdynamic -liconv -lm
gcc: unrecognized option `-rdynamic'

---- stop ----

Now when I run 'gmake install' after 'gmake uninstall' to remove all
traces of the previous version I had installed, I'm getting this result:

---- start ----

if test ! -d /usr/local/bin ; then mkdir -p /usr/local/bin ; fi
/usr/ucb/install -m 755 -s mplayer /usr/local/bin/mplayer
ln -sf mplayer /usr/local/bin/gmplayer
if test ! -d /usr/local/man/man1 ; then mkdir -p /usr/local/man/man1; fi
for i in en; do \
	if test "$i" = en ; then \
		/usr/ucb/install -c -m 644 DOCS/man/en/mplayer.1 /usr/local/man/man1/mplayer.1 ; \
	else \
		mkdir -p /usr/local/man/$i/man1 ; \
		/usr/ucb/install -c -m 644 DOCS/man/$i/mplayer.1 /usr/local/man/$i/man1/mplayer.1 ; \
	fi ; \
/usr/ucb/install -m 755 -s mencoder /usr/local/bin/mencoder
for i in en; do \
	if test "$i" = en ; then \
		ln -sf mplayer.1 /usr/local/man/man1/mencoder.1 ; \
	else \
		ln -sf mplayer.1 /usr/local/man/$i/man1/mencoder.1 ; \
	fi ; \
*** Download font at http://www.mplayerhq.hu/homepage/dload.html
*** for OSD/Subtitles support and extract to /usr/local/share/mplayer/font/
*** Download skin(s) at http://www.mplayerhq.hu/homepage/dload.html
*** for GUI, and extract to /usr/local/share/mplayer/Skin/
/usr/ucb/install -m 644 Gui/mplayer/pixmaps/mplayer-desktop.xpm /usr/local/share/pixmaps/mplayer-desktop.xpm
/usr/ucb/install -m 644 etc/mplayer.desktop /usr/local/share/applications/mplayer.desktop

---- stop ----

And that should theoretically be completed since I already have
/usr/local/share/mplayer filled with things used by previous versions, so
when I run the mplayer binary that was installed by the 'gmake install'
step, I shouldn't be getting this:

---- start ----

ld.so.1: mplayer: fatal: libstdc++.so.5: open failed: No such file or directory

---- stop ----

One possibility is that part of the make process is not recognising the
defaults I use for the -L and -R linker flags which are:


I'm not sure how to check that these paths (via the LDFLAG environment
variable that's set up whenever I start up a root shell to compile things)
are being used properly.

If the compile process isn't failing, what would cause the mplayer binary
to not find the libstdc++.so.5 shared lib at runtime?



More information about the MPlayer-users mailing list