[MPlayer-users] problem with realplayer file ra

Mitchell Laks mlaks at verizon.net
Wed Aug 3 21:18:03 CEST 2005


I am having trouble converting a realplayer file to anything using mplayer. 
Also can't play it using mplayer. It plays on realplay from real networks, 
however it just sounds like running water on mplayer (instead of a lecture by 
my teacher).

i uploaded the file, called 

to the mplayer incoming ftp site.

i tried the mplayer version from debian sid and marillat,
i also compiled and tested the latest cvs version. 

i also loaded onto the mplayer fip site also my system information, to help if 
that makes a difference. i called the information file
to the site as well. 

Thus there are two files that are relevant.

oops I forgot to bunzip2 them! 

I did the install from the cvs snapshot

but did not do make install. 
I just ran ./mplayer from the make directory 

Now i tried running with
mplayer -v gitten_13.ra

and i get the following output.

mlaks at RAMBAM:~/mplayer_download/MPlayer-20050727$ ./mplayer
-v /home/mlaks/schec
MPlayer dev-CVS-050727-00:00-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

CommandLine: '-v' '/home/mlaks/schechter/gittin_13.ra'
get_path('font/font.desc') -> '/home/mlaks/.mplayer/font/font.desc'
font: can't open file: /home/mlaks/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/home/mlaks/.mplayer/input.conf'
Can't open input config file /home/mlaks/.mplayer/input.conf: No such file or
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file
Falling back on default (hardcoded) input config
get_path('gittin_13.ra.conf') -> '/home/mlaks/.mplayer/gittin_13.ra.conf'
Playing /home/mlaks/schechter/gittin_13.ra.
[file] File size is 7916620 bytes
STREAM: [file] /home/mlaks/schechter/gittin_13.ra
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo
Checking for REAL
Checking for SMJPEG
REALAUDIO file format detected.
==> Found audio stream: 0
[RealAudio] File version: 4
[RealAudio] Frame size: 304
[RealAudio] Sub packet size: 0
[RealAudio] 1 channel, 16 bit, 8000Hz
Audio: Unknown (1919969651)
======= WAVE Format =======
Format Tag: 26995 (0x6973)
Channels: 1
Samplerate: 8000
avg byte/sec: 16000
Block align: 304
bits/sample: 16
cbSize: 0
Clip info:
 Title: Maseches Gittin - Shiur # 13
 Author: Rav Herschel Schachter
 Copyright: 10/13/99
Opening audio decoder: [realaud] RealAudio decoder
opening shared obj '/usr/local/lib/codecs/sipr.so.6.0'
Audio codec: [0] 6.5 Kbps Voice
Audio bitrate: 6.500 kbit/s (813 bps)
dec_audio: Allocating 7600 bytes for input buffer.
dec_audio: Allocating 128000 + 65536 = 193536 bytes for output buffer.
AUDIO: 8000 Hz, 1 ch, s16le, 6.5 kbit/5.08% (ratio: 813->16000)
Selected audio codec: [rasipr] afm:realaud (RealAudio Sipro)
Building audio filter chain for 8000Hz/1ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 8000Hz/1ch/s16le
[dummy] Was reinitialized: 8000Hz/1ch/s16le
ao2: 8000 Hz  1 chans  s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 1 channels (requested: 1)
audio_setup: using 8000 Hz samplerate (requested: 8000)
audio_setup: frags:   8/8  (8192 bytes/frag)  free:  65536
AO: [oss] 8000Hz 1ch s16le (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 8000Hz/1ch/s16le -> 8000Hz/1ch/s16le...
[dummy] Was reinitialized: 8000Hz/1ch/s16le
[dummy] Was reinitialized: 8000Hz/1ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
A:  66.1 (01:06.0)  1.0%

MPlayer interrupted by signal 2 in module: play_audio
Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: realaud
vo: x11 uninit called but X11 not inited..

any ideas?



More information about the MPlayer-users mailing list