[MPlayer-users] Re: convert rmvb file to mpeg

benjamin yau yaucwb at homemail.com.au
Sat Apr 30 01:22:45 CEST 2005

thanks Nico & Konrad

> If you play it in mplayer it shows the same error?
No, mplayer plays the file just fine.

> Try with -fps 23 -ofps 23.
> Have you tired to record it to AVI container?
> he's been doing it all along if he didn't specify -of mpeg

$ mencoder /mnt/cdrom/16.rmvb -o 16.mpg -oac copy -ovc lavc lavcopts vcodec=mpeg2video -idx -ni -fps 23 -ofps 23

$ mencoder /mnt/cdrom/16.rmvb -o 16.mpg -oac copy -ovc lavc lavcopts vcodec=raw -of mpeg -idx -ni -fps 23 -ofps 23

Tried both above commands and got the same error (Too many video packets in the buffer:...) as before.

when compared the messages from mplayer and mencoder,

- they have the same complaint about "Something went wrong, no index chunk found on given address..."

- they use the same video decoder and video codec correctly

	Opening video decoder: [realvid] RealVideo decoder
	opening shared obj '/usr/local/lib/codecs/drvc.so'
	Selected video codec: [rv3040] vfm:realvid (Linux RealPlayer 10 RV30/40 decoder)

- mplayer had "Movie-Aspect is 1.33:1 - prescaling to correct movie aspect..  ", mencoder had "ODML: Aspect information not (yet?) available or unspecified, not writing vprp header."  Not specifying Aspect info shouldn't have caused such an error.

This is rather strange with mplayer fine but mencoder failed.  I checked whether it is a performance issue, "cat /proc/mtrr" looked fine.


More information about the MPlayer-users mailing list