[MPlayer-users] DVD Seek lockup - strange noise

Jynx jynx at thescrapyard.org
Thu Apr 28 10:10:21 CEST 2005

I was using libdvdread to see if it made a difference - exactly the same 
problem occurrs mpdvdkit2. As for sdl, that just seems to render fastest 
on my computer so I'm in the habit of automatically specifying it.
I don't understand what you mean by incomplete. When I run mplayer it 
gets to that point and locks up. After about a minute or two of wirring, 
I'll hit ctrl-c or kill it from another terminal, and after about 
another half minute, mplayer suddenly exits with a message about 
receiving a signal (whatever I killed it with). No other output is 
Downloaded the CVS, but didn't help. Attached the output (It's running 
as root as I just installed it)


RC wrote:

>Okay, in that case, why are you using the old libdvdread method, rather
>than MPlayer's default compiled-in "mpdvdkit2"?  Why are you using sdl
>for vo and ao?  Your mplayer output is obviously incomplete...  If it
>hangs there, kill the process, but you also need to include the output
>afterwards for anyone to be able to help.  Pre6 is also fairly old now,
>you should be using a CVS snapshot or at least pre7, to see if the
>problem has been fixed already.
root at tartarus:/usr/local/src/MPlayer-cvs/main# mplayer dvd://6 -v
MPlayer dev-CVS-050428-09:25-3.3.4 (C) 2000-2005 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, 
Stepping: 3)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

CommandLine: 'dvd://6' '-v'
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or 
Can't open input config file /usr/local/etc/mplayer/input.conf: No such 
file or directory
Falling back on default (hardcoded) input config
get_path('6.conf') -> '/root/.mplayer/6.conf'
Playing dvd://6.
get_path('DVDKeys') -> '/root/.mplayer/DVDKeys'
Reading disc structure, please wait...
There are 7 titles on this DVD.
There are 39 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
[open] audio stream: 0 audio format: dts (5.1/6.1) language: ja aid: 136
[open] audio stream: 1 audio format: ac3 (5.1) language: en aid: 129
[open] number of audio channels on disk: 2.
[open] subtitle ( sid ): 0 language: en
[open] number of subtitles on disk: 1
DVD start cell: 0  pack: 0x0-0x1344C
DVD start=0 end=3356913
DVD Seek! lba=0x0  cell=0  packs: 0x0-0x1344C
Angle-seek synced by cell/vob IDN search!
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename dvd://6 ext: (null)
Checking for MOV
Checking for VIVO
header block 1 size: 0
DVD Seek! lba=0x0  cell=0  packs: 0x0-0x1344C
Angle-seek synced by cell/vob IDN search!
AVS: avs_check_file - attempting to open file dvd://6
AVS: File is too big, aborting...
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 70295, FOUND 47, packet_size= 0, SEEMS A TS? 0
DVD Seek! lba=0x22  cell=0  packs: 0x0-0x1344C
Angle-seek synced by cell/vob IDN search!
DVD Seek! lba=0x0  cell=0  packs: 0x0-0x1344C
Angle-seek synced by cell/vob IDN search!
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=1140851708
LMLM4 Stream Format not found
system stream synced at 0xD (0)!
==> Found video stream: 0
dvd_next_cell: next1=0x0
dvd_next_cell: next2=0x0
dvd_next_cell: next3=0x1
dvd_next_cell: next1=0x1
dvd_next_cell: next2=0x1
dvd_next_cell: next3=0x2
dvd_next_cell: next1=0x2
dvd_next_cell: next2=0x2
dvd_next_cell: next3=0x3
dvd_next_cell: next1=0x3
dvd_next_cell: next2=0x3
dvd_next_cell: next3=0x4
dvd_next_cell: next1=0x4
dvd_next_cell: next2=0x4
dvd_next_cell: next3=0x5
dvd_next_cell: next1=0x5
dvd_next_cell: next2=0x5
dvd_next_cell: next3=0x6
dvd_next_cell: next1=0x6
dvd_next_cell: next2=0x6
dvd_next_cell: next3=0x7
dvd_next_cell: next1=0x7
dvd_next_cell: next2=0x7
dvd_next_cell: next3=0x8
dvd_next_cell: next1=0x8
dvd_next_cell: next2=0x8
dvd_next_cell: next3=0x9
dvd_next_cell: next1=0x9
dvd_next_cell: next2=0x9
dvd_next_cell: next3=0xA
dvd_next_cell: next1=0xA
dvd_next_cell: next2=0xA
dvd_next_cell: next3=0xB
dvd_next_cell: next1=0xB
dvd_next_cell: next2=0xB
dvd_next_cell: next3=0xC
dvd_next_cell: next1=0xC
dvd_next_cell: next2=0xC
dvd_next_cell: next3=0xD
dvd_next_cell: next1=0xD
dvd_next_cell: next2=0xD
dvd_next_cell: next3=0xE
dvd_next_cell: next1=0xE
dvd_next_cell: next2=0xE
dvd_next_cell: next3=0xF
dvd_next_cell: next1=0xF
dvd_next_cell: next2=0xF
dvd_next_cell: next3=0x10
dvd_next_cell: next1=0x10
dvd_next_cell: next2=0x10
dvd_next_cell: next3=0x11
dvd_next_cell: next1=0x11
dvd_next_cell: next2=0x11
dvd_next_cell: next3=0x12
dvd_next_cell: next1=0x12
dvd_next_cell: next2=0x12
dvd_next_cell: next3=0x13
DVD Seek! lba=0x199BFE  cell=19  packs: 0x195390-0x1A84F6

MPlayer interrupted by signal 2 in module: demux_open
vo: x11 uninit called but X11 not inited..
root at tartarus:/usr/local/src/MPlayer-cvs/main#

More information about the MPlayer-users mailing list