[MPlayer-users] mplayer hangs on imac thin client K12LTSP

Mike Thostenson mthostenson at thostenson.net
Tue Apr 26 02:10:09 CEST 2005

Hi all,

I have put together a K12LTSP (4.2.1) server for the local city library to
use. New to K12LTSP 4.2.1 is the possibility to boot an imac over the
network and run linux apps using the imac as a thin client. I have
everything working including sound through esd...with one
exception..mplayer. It hangs like the below mplayer -v output when I try
to play a video. I have tried many, many different vo options and video
media formats...they all seem to hang. I am guessing that there is
something else that I need to add to my XF86Config-4.indigo which is
called from /opt/ltsp/ppc/etc/lts.conf I have attached my outputs and a
couple configs below. I have tried several different window managers..they
all do this. I have tried building mplayer from source...same results. I
am currently running icewm as the window manager. If I set the vo to null
I get audio and everything just fine. If I set vo to x11 it runs with
audio..but I get no video. All of the intel based terminals work just fine
with audio and video. I intend on writing a howto for the imac thin client
setups...PLEASE HELP me resolve this last little issue.:

************begin mplayer -v output***********************
mplayer -v mx2003.wmv
MPlayer 1.0pre7-RPM-3.4.2 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with

CommandLine: '-v' 'mx2003.wmv'
get_path('font/font.desc') -> '/home/mthostenson/.mplayer/font/font.desc'
font: can't open file: /home/mthostenson/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system
startup scripts.
Using nanosleep() timing
get_path('input.conf') -> '/home/mthostenson/.mplayer/input.conf'
Can't open input config file /home/mthostenson/.mplayer/input.conf: No
such file  or directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 59 binds
get_path('mx2003.wmv.conf') -> '/home/mthostenson/.mplayer/mx2003.wmv.conf'
Playing mx2003.wmv.
[file] File size is 59997504 bytes
STREAM: [file] mx2003.wmv
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0  pre:1677721  eof:0
Cache fill:  0.00% (0 bytes)    Checking for YUV4MPEG2
ASF file format detected.
stream type: guid_audio_stream
stream concealment: guid_audio_conceal_interleave
type: 28 bytes,  stream: 8 bytes  ID: 1
unk1: 0  unk2: 5F0FCE4
==> Found audio stream: 1
======= WAVE Format =======
Format Tag: 353 (0x161)
Channels: 2
Samplerate: 44100
avg byte/sec: 20005
Block align: 3716
bits/sample: 16
cbSize: 10
Unknown extra header dump: [0] [88] [0] [0] [f] [0] [21] [74] [0] [0]
ASF: audio scrambling: 1 x 1 x -124
stream type: guid_video_stream
stream concealment: unknown guid 0057fb20-555b-cf11-a8fd00805f5c442b
type: 55 bytes,  stream: 0 bytes  ID: 2
unk1: 0  unk2: 52A0748
==> Found video stream: 2
======= VIDEO Format ======
  biSize 44
  biWidth 640
  biHeight 480
  biPlanes 1
  biBitCount 24
  biCompression 861293911='WMV3'
  biSizeImage 0
Unknown extra header dump: [4f] [d1] [12] [1]
ASF: packets: 7499  flags: 2  max_packet_size: 8000  min_packet_size: 8000
 max_ bitrate: 2079808  preroll: 1578

 Title: riding2

============ ASF Stream group == START ===
 stream count=[0x2][2]
   stream id=[0x1][1]
   max bitrate=[0x2801a][163866]
   stream id=[0x2][2]
   max bitrate=[0x1d3c26][1915942]
============ ASF Stream group == END ===
Found movie at 0xB9A - 0x393735A
ASF: 1 audio and 1 video streams found
Auto-selected ASF audio ID = 1
Auto-selected ASF video ID = 2
ASF: Searching for audio stream (id:1).
VIDEO:  [WMV3]  640x480  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:6  fourcc:0x33564D57  size:640x480  fps:1000.00  ftime:=0.0010
Clip info:
 name: riding2
get_path('sub/') -> '/home/mthostenson/.mplayer/sub/'
get_path('default.sub') -> '/home/mthostenson/.mplayer/default.sub'
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 131072 + 65536 = 196608 bytes for output buffer.
FFmpeg's libavcodec audio codec
INFO: libavcodec init OK!
AUDIO: 44100 Hz, 2 ch, s16le, 160.0 kbit/11.34% (ratio: 20005->176400)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (FFmpeg))
X11 opening display: ws084.ltsp:0.0
vo: X11 color mask:  FFFFFF  (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1024x768 with depth 24 and 32 bpp ("ws084.ltsp:0.0" =>
remote  display)
[x11] Detected wm supports layers.
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Current fstype setting honours LAYER FULLSCREEN ABOVE BELOW X atoms

*******************end mplayer -v output************************

*******************begin XF86Config-4.indigo********************
Section "Files"
        #FontPath       "/usr/X11R6/lib/X11/fonts/local/"
        FontPath        "tcp/"                       #
local font server
        # if the local font server has problems, we can fall back on these
        FontPath        "/usr/X11R6/lib/X11/fonts/misc"
        FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
        FontPath        "/usr/X11R6/lib/X11/fonts/CID"
        FontPath        "/usr/X11R6/lib/X11/fonts/Speedo"
        FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
        FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
        # paths to defoma fonts
        #FontPath       "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        #FontPath       "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

Section "Module"
        Load    "GLcore"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "v4l"
        Load    "vbe"

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "macintosh"
        Option          "XkbLayout"     "us"

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"

Section "Device"
        Identifier      "ATI Technologies, Inc. Rage 128 PR/PRO (AGP TMDS)"
        Driver          "ati"
        Option          "UseFBDev"              "true"

Section "Monitor"
        Identifier      "iMac"
        HorizSync       60-60
        VertRefresh     75-117
#       Option          "DPMS"

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. Rage 128 PR/PRO (AGP TMDS)"
        Monitor         "iMac"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "800x600" "640x480"
        SubSection "Display"
                Depth           4
                Modes           "800x600" "640x480"
        SubSection "Display"
                Depth           8
                Modes           "800x600" "640x480"
        SubSection "Display"
                Depth           15
                Modes           "800x600" "640x480"
        SubSection "Display"
                Depth           16
                Modes           "800x600" "640x480"
        SubSection "Display"
                Depth           24
                Modes           "800x600" "640x480"

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"

Section "DRI"
        Mode    0666
*******************end XF86Config-4.indigo**********************

*******************begin /opt/ltsp/ppc/etc/lts.conf***************
        SERVER             =
        XSERVER            = auto
        X_MOUSE_PROTOCOL   = "auto"
        X_MOUSE_DEVICE     = "/dev/input/mice"
        X_MOUSE_RESOLUTION = 400
        X_MOUSE_BUTTONS    = 3
        X_DEVICE_OPTION_01 = "UseFBDev\" \"true"
        USE_XFS            = N
        LOCAL_APPS         = N
        SCREEN_01          = startx
        #SCREEN_01          = shell

        # enable sound by default
        SOUND              = Y
        # choose either esd or nasd to be the default
#        SOUND_DAEMON       = "nasd"
         SOUND_DAEMON     = "esd"

        # default sound volume
        VOLUME             = 99

        XSERVER         = r128
        XF86CONFIG_FILE = XF86Config-4.indigo
        X4_MODULE_01    = glx
        SMODULE_01      = "soundcore.o"
        SMODULE_02      = "dmasound_pmac.o"
        SMODULE_03      = "dmasound_core.o"
*******************begin /opt/ltsp/ppc/etc/lts.conf***************

More information about the MPlayer-users mailing list