[MPlayer-users] mplayer and joined mpg files by mpgtx -j

Jouni.Lohikoski@iki.fi jlohikos at cc.hut.fi
Wed Apr 13 21:16:45 CEST 2005

On Wed, Apr 13, 2005 at 03:09:56PM +0200, Nico Sabbi wrote:
> I didn't have any problem, but I use by default -mc 0.1

That didn't fix the problem for me.

I bet your mplayer is using ffmpeg codec for playing it?

For me, by defult it uses these:
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))

Then I tried with ffplay. It playes it as well as xine. So Totem and
mplayer is failing. So I tried:
$ mplayer -vc ffmpeg1 test.mpg

...and it works. So it is a bug in libmpeg2-v0.4.0b (?)

On Wed, Apr 13, 2005 at 04:28:28PM +0100, Martin Collins wrote:
> Yes. I usually get round it by editing out some frames either side
> of the join with avidemux.

Could you try if "-vc ffmpeg1" fixes the problem for you too?

// jouni

More information about the MPlayer-users mailing list