[MPlayer-users] Re: RDT chunk not recognized, again :( Whats wrong??

tkondziola at o2.pl tkondziola at o2.pl
Tue Sep 28 13:58:14 CEST 2004

I've just observated that when I ran mplayer without -sstep options
everything is ok (mplayer is running without any problems).
Any idea why?.

>Date: Tue, 28 Sep 2004 10:48:39 +0200
>From: tkondziola at o2.pl
>Subject: [MPlayer-users] RDT chunk not recognized, again :( Whats
>	wrong??
>To: mplayer-users at mplayerhq.hu
>Message-ID: <20040928084838.C30BA37F16 at rekin11.go2.pl>
>Content-Type: text/plain; charset="iso-8859-2";
>    Once again I've got a problem with real stream. I use Helix
>Producer and Helix DNA Server to produce a real stream. I use
>MPlayer to received a frame from stream (MPlayer
>    The problem is the same like in my previous letter, which I send
>to mplayer-users mailing list. Below I inserted information which I
>received when I ran mplayer:
>In command line I wrote:
>./mplayer -cache 32 -sstep 10 -vo jpeg -nosund
>Later I received following messages:
>MPlayer dev-CVS-040928-06:00-3.3.2 (C) 2000-2004 MPlayer Team
>CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville 902.7 MHz
>(Family: 6, Stepping: 10)
>Detected cache-line size is 32 bytes
>CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
>Compiled for x86 CPU with extensions: MMX MMX2 SSE
>Reading config file /root/MPlayer/etc/mplayer/mplayer.conf: No such
>file or directory
>Reading config file /root/.mplayer/config
>Reading /root/.mplayer/codecs.conf: Can't open
>'/root/.mplayer/codecs.conf': No such file or directory
>Reading /root/MPlayer/etc/mplayer/codecs.conf: Can't open
>'/root/MPlayer/etc/mplayer/codecs.conf': No such file or directory
>Using built-in default codecs.conf.
>font: can't open file: /root/.mplayer/font/font.desc
>font: can't open file: /root/MPlayer/share/mplayer/font/font.desc
>Using Linux hardware RTC timing (1024Hz).
>Can't open input config file /root/.mplayer/input.conf: No such file
>or directory
>Can't open input config file /root/MPlayer/etc/mplayer/input.conf:
>No such file or directory
>Falling back on default (hardcoded) input config
>Playing rtsp://xxx.xxx.xx.x/broadcast/gdansk.rm.
>Connecting to server xxx.xxx.xx.x[xxx.xxx.xx.x]:554 ...
>Cache size set to 32 KBytes
>Connected to server:
>Cache fill:  0.00% (0 bytes)    REAL file format detected.
>demux_real: invalid chunksize! (0)
>VIDEO:  RV30 [30203002,00091030]  128x100  (aspect 0.00)  15.00 fps
>VIDEO:  [RV30]  128x100  24bpp  15.000 fps    0.0 kbps ( 0.0 kbyte/s)
>jpeg: Parsing suboptions.
>jpeg: Suboptions parsed OK.
>Opening video decoder: [realvid] RealVideo decoder
>opening shared obj '/usr/local/lib/codecs//drv3.so.6.0'
>Selected video codec: [rv30] vfm:realvid (Linux RealPlayer 8 RV30
>Audio: no sound
>Starting playback...
>VDec: vo config request - 128 x 100 (preferred csp: Planar I420)
>Could not find matching colorspace - retrying with -vf scale...
>Opening video filter: [scale]
>VDec: using Planar I420 as output csp (no 0)
>Movie-Aspect is 1.28:1 - prescaling to correct movie aspect.
>No accelerated colorspace conversion found
>SwScaler: using unscaled Planar YV12 -> RGB 24-bit special converter
>VO: [jpeg] 128x100 => 128x100 RGB 24-bit
>jpeg: . - Output directory already exists and is writable.
>rdt chunk not recognized: got 0x4f 0 0 0%%
>rdt chunk not recognized: got 0x2a
>V:   0.0    8   0%  0%  0.0% 0 0 0%
>Exiting... (End of file)
>Question is whats wrong with mplayer or Helix DNA Server or Helix
>PS. I'd like to say that when I'm watching this stream in
>RealOnePlayer everything is ok.
>MPlayer-users mailing list
>MPlayer-users at mplayerhq.hu
>End of MPlayer-users Digest, Vol 9, Issue 96

More information about the MPlayer-users mailing list