[MPlayer-users] trouble compiling mplayer

Rajarshi Guha rxg218 at psu.edu
Fri Sep 24 16:46:03 CEST 2004

Hi, I've downloaed the latest tarball for mplayer (MPlayer-1.0pre5) and
am having trouble compiling it.

I ran configure as

./configure --prefix=/usr/local 

and then ran make. The compile stops with the error:

In file included from native/decode144.c:3:
native/tables144.h:751:8: invalid suffix "yfcaf" on integer constant
In file included from native/decode144.c:3:
native/tables144.h:751: error: initializer element is not constant
native/tables144.h:751: error: (near initialization for
native/tables144.h:767: warning: overflow in implicit constant
native/tables144.h:768: warning: overflow in implicit constant
make[1]: *** [native/decode144.o] Error 1
make[1]: Leaving directory
make: *** [libmpcodecs/libmpcodecs.a] Error 2

I'm not sure how to procede - is this a bug in the code?
Any pointers would be appreciated

My system is:

AMD Athlon 1GHz
Fedora Core 2
gcc (GCC) 3.3.3 20040412 (Red Hat Linux 3.3.3-7)
kernel:  2.6.5-1.358

Another problem I was having was with the LiveMedia libs. I noted a few
posts on the net regarding a problem with the 7-19 version and a patch
for the 7-16 version. However it appears that the 9-22 version also
gives the same error. Has anybody gotten around this or do we need to
wait for Live to fix the problem?


Rajarshi Guha <rxg218 at psu.edu> <http://jijo.cjb.net>
GPG Fingerprint: 0CCA 8EE2 2EEB 25E2 AB04 06F7 1BB9 E634 9B87 56EE
Does Ramanujan know Polish?
-- E.B. Ross

More information about the MPlayer-users mailing list