[MPlayer-users] Output to file question.

Nathan Lavertue nlavertue at gmail.com
Thu Sep 23 23:27:42 CEST 2004

I'm trying to output a RTSP stream to a file using mplayer, on Mac OS X.

I've tried using precompiled binaries, installing the binaries myself
(with the LIVE.COM libraries) and several different input commands.

I've gotten mplayer to open the streams, and play them just 'ok'. But
it can't output the information to a file. This is the stream in
question - rtsp://real.sony.global.speedera.net/real.sony.global/qt/CypressHill/CypressHill_WhatsYourNumberVid_300.mov

I've tried...
mplayer -dumpstream
mplayer -dumpfile stream.mov -dumpstream

and several other variations, but, again, nothing seems to actually
output anything.  It only hangs the Terminal, and when I have force
quit it gives the following error message.
Playing rtsp://real.sony.global.speedera.net/real.sony.global/qt/CypressHill/CypressHill_WhatsYourNumberVid_300.mov.
Resolving real.sony.global.speedera.net for AF_INET6...
Couldn't resolve name for AF_INET6: real.sony.global.speedera.net
Resolving real.sony.global.speedera.net for AF_INET...
Connecting to server real.sony.global.speedera.net[]:554 ...
rtsp_session: session can not be established.
Not a Realmedia rtsp url. Trying standard rtsp protocol.
Connected to server: real.sony.global.speedera.net
Cannot dump this stream - no 'fd' available

Exiting... (Fatal error)
When I do the -dumpfile only for the .mov stream, it opens the file,
but it doesn't try to write any of the data.


More information about the MPlayer-users mailing list