[MPlayer-users] RealMedia - what RealAudio formats work?

Roberto Togni r_togni at tiscali.it
Tue Sep 14 21:50:06 CEST 2004

On 2004.09.14 15:42, Tony Robinson wrote:
> I've spent days and days bashing around trying everything to get
> RealAudio to stream in mplayer.
> I've tried MPlayer-1.0pre5 and the recent releases MPlayer-20040908
> MPlayer-20040910, with and without the recent liveMedia
> live.2004.09.08
> and live.2004.09.09.
> I've unpacked all-20040809.tar into /usr/local/lib/codecs/ 
> all-20040809
> and for good measure I have the latest RealPlayer codecs as well (in
> /usr/local/Linux/RealPlayer10GOLD/codecs).
> However, on test audio that has been mentioned here before I get:
> compute ajr: ./mplayer 'rtsp://rmv8.bbc.net.uk/news/olmedia/cta/ 
> progs/rn/rn_v7.rm'
> MPlayer dev-CVS-040910-05:00-3.3.4 (C) 2000-2004 MPlayer Team
> CPU: Intel Pentium III Katmai/Pentium III Xeon Tanner 563.7 MHz
> (Family: 6, Stepping: 3)
> Detected cache-line size is 32 bytes
> CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
> Compiled for x86 CPU with extensions: MMX MMX2 SSE
> Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file
> or directory
> Reading config file /home/echidna0/ajr/.mplayer/config
> Reading /home/echidna0/ajr/.mplayer/codecs.conf: 74 audio & 180 video
> codecs
> font: can't open file: /home/echidna0/ajr/.mplayer/font/font.desc
> font: can't open file: /usr/local/share/mplayer/font/font.desc
> Failed to open /dev/rtc: Permission denied (it should be readable by
> the user.)
> Using nanosleep() timing
> Input config file /home/echidna0/ajr/.mplayer/input.conf parsed: 53
> binds
> Playing rtsp://rmv8.bbc.net.uk/news/olmedia/cta/progs/rn/rn_v7.rm.
> Resolving rmv8.bbc.net.uk for AF_INET...
> Connecting to server rmv8.bbc.net.uk[]:554 ...
> rtsp_session: Not a Real server. Server type is 'unknown'.
That's the problem. The server type should not be unknown. For Real  
streams i's "Real" or "Helix" (it's not printed on console output),  
unknown is printed when there is no "Server" header and  no  
"RealChallenge1" in the headers.

> Not a Realmedia rtsp url. Trying standard rtsp protocol.
Not being able to recognize it as a realrtsp stream, MPlayer falls back  
to standard rtsp protocol.

> Connected to server: rmv8.bbc.net.uk
> Stream not seekable!
> Failed to initiate "audio/X-PN-REALAUDIO" RTP subsession: RTP payload
> format unknown or not supported
and that obviously fails
> MPlayer interrupted by signal 11 in module: demux_open
But sig11 should not happen anyway :(

> I've also tried Debian packages and RPMs with no luck.
> The other test audio mentioned here is
> rtsp://mm4.rai.it/raitre/blob/ultimo/blob.rm
Both streams work here, even with pre5

You don't seem to do anything wrong.
anyway, the problem is not codec related (it crashes long before  
reaching codec open), and also live.com is not used for realrtsp, so  
it's not part of the problem.

Are you able to play them with other programs (xine ot RealPlayer)?  
Maybe is some network problem.


More information about the MPlayer-users mailing list