[MPlayer-users] Sound or picture - not both

Steve Mansfield lists at webvivant.com
Fri Sep 10 18:21:36 CEST 2004

Seems I sent my original reply to this privately, rather than to the list, so 
here goes again, with an update

| On Thursday 09 September 2004 03:04 pm, Steve Mansfield wrote:
| > Okay, I have googled on this, I swear. I'm having problems with Mplayer &
| > mplayerplug-in - with Quicktime I can see the image, but no sound, with
| > Windows files it's the other way around.
| >
| > I'm using SuSE 8.2, Firefox 0.9.1 and Moz 1.7.
| >
| > I downloaded, built & installed MPlayer 1.0pre5-3.3. I downloaded the
| > full set of codecs which are in the default dir /usr/local/lib/codecs.
| >
| > I built & installed mplayerplug-in 2.66.
| >
| > When I click on a link for a video clip, the plug in appears in the
| > browser, I get messages telling me that it's connecting, dowloading and
| > cacheing, and then the file starts to play but - as I said - Quicktime
| > movies have no sound and Windows movies sound but no picture.
| You need to make sure you have compiled mplayer with faad 1.2 or 2.0
| support to get sound from quicktime movies.

Thanks. I tried recompiling with --enable-external-faad - the only faad option 
I could find, but still no sound with Quicktime.

| Also, I believe your codecs need to be in /usr/lib/win32 unless you
| configured mplayer to look in a different spot.

Not any more, according to the README, viz:

"Unpack the codecs archives and put the contents in a directory where MPlayer
will find them. The default directory is /usr/local/lib/codecs/ (it used to be
/usr/local/lib/win32 in the past, this also works)"

But... I copied all the codecs into /usr/local/lib/win32 and the Windows media 
option is now working! I think the README needs work.


More information about the MPlayer-users mailing list