[MPlayer-users] Seeking in MP4 files

Jürg Lehni juerg at scratchdisk.com
Thu Sep 2 17:51:38 CEST 2004

I already tried -forceidx and -idx, and I tried again: It doesn't help. 
But isn't this for avi anyhow and doesn't do anything for mp4?


Am 02.09.2004 um 17:44 schrieb Torinthiel:

> On Thu, Sep 02, 2004 at 05:29:45PM +0200, Jürg Lehni wrote:
>> So I rebuilt the mplayer with aa support now, and watched one of my
>> movies through the ssh terminal (which is pretty beautifull, btw :):
>> The movie is defenitelly not seekable. Whenever I click on right 
>> arrow,
>> it jumps to the beginning of the file.
>> Is there anything I can do about this?
>> It would be so nice to use mplayer for the thumbnail generation.
>> For example is there an option to tell the mplayer to skip the first n
>> frames? I would be fine with that... If this option doesn't exist (I
>> didn't find anything about this in the man pages), should it be added?
> It's not much needed ;)
> Ok, so if -idx doesn't work than either the stream is really not
> seekable, which would be quite strange and nothing except recoding can
> be done, or, more probably, the index is corrupt. -forceidx makest
> things better?
> Note, it takes some time and has to be redone on every play of the
> movie.
> If you know you will be using it do
> mencoder -forceidx -ovc copy -oac copy file -o file2
> Torinthiel
> -- 
>  Waclaw "Torinthiel" Schiller       GG#: 542916, 3073512
>    torinthiel(at)megapolis(dot)pl
>    gpg: B06901F1 fpr: FAA3 559F CAE9 34DE CDC8  7346 2B6E 39F2 B069 
> 01F1
>  "No classmates may be used during this examination"
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> http://mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list