[MPlayer-users] Seeking in MP4 files

Jürg Lehni lehni at gmx.net
Thu Sep 2 12:04:10 CEST 2004


I'm trying to use mplayer for automatic generation of thumbnails on the 
server. Often the first frames of films do not really make sense, 
that's why i'd like to take an image from somewhere in the middle 
instead of just the first few frames.

So I'm doing something like this:

mplayer -nosound -frames 1 -ss 50 -vo jpeg moviefile

while this works nicely with for example quicktime files (.mov), I have 
troubles with mp4 files which I generated on the mac with quicktime as 

They don't seem to be seekable. Is this just a problem with the way 
I've built mplayer, or is this a general problem? I've tried to find 
something about this on the web but information about MP4 in mplayer is 
very rare.

I also tried to ues different codecs, with no luck:

mplayer -nosound -vfm odivx -frames 1 -ss 50 -vo jpeg movie.mp4

If someone could point me to a solution I would be more than happy. The 
solution maybe be a dirty hack, I don't really care. :)


More information about the MPlayer-users mailing list