[MPlayer-users] Need help with building a movie out of jpegs with mencoder on windows xp

David R. Noriega david at comicastle.com
Wed Sep 1 01:51:04 CEST 2004

Hello all,

I have searched for an answer in the mailing lists (and google) to no 
avail, so apologies if this was indeed resolved before.

I would like to compile a movie, preferably avi, preferably using divx 
from a series of jpegs that my web cam saves to a directory.

I downloaded the windows version of mplayer and unzipped the files 
preserving the directory structure in a directory of my computer.

I copied the jpegs to a "test" directory  where mplayer/mencoder bin 
files reside.

I ran the following command:
C:\Program Files\mplayer>mencoder mf://test\*.jpg -mf 
w=640:h=480:fps=6:type=jpeg -ovc copy -o ccgda.avi -nosound

The result:
MEncoder 1.0pre5-3.2.3 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 2373 MHz (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags: Type: 8 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with 
Reading C:/Program Files/mplayer/mplayer/codecs.conf: Can't open 
'C:/Program Files/mplayer/mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open 
'/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
File not found: 'frameno.avi'
Failed to open frameno.avi
Reading config file C:/Program Files/mplayer/mplayer/mencoder: No such 
file or directory
font: can't open file: C:/Program Files/mplayer/mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
success: format: 16  data: 0x0 - 0x0
[demuxer] mf support.
[mf] search expr: test\*.jpg
[mf] number of files: 430 (1720)
[V] filefmt:16  fourcc:0x47504A49  size:640x480  fps: 6.00  ftime:=0.1667
videocodec: framecopy (640x480 24bpp fourcc=47504a49)
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not 
writing vprp header.

Writing AVI index...
Fixing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not 
writing vprp header.

Video stream:   -1.#IO kbit/s  (-2147483648 bps)  size: 0 bytes  0.000 
secs  0 frames

As you can see, the resulting file was very small - about 5k with no 
video in it at all.

If I run:
C:\Program Files\mplayer>mencoder mf://test\*.jpg -mf 
w=640:h=480:fps=6:type=jpeg -ovc lavc -o ccgda.avi -nosound
(note lavc option instead of copy)
I get a fault error.

The documentation states:

*Explanation of the process:*


      *MEncoder* /decodes/ the input image(s) with libjpeg (when
      decoding PNGs, it will use libpng).


      *MEncoder* then feeds the decoded image to the chosen video
      compressor (DivX4, Xvid, ffmpeg msmpeg4, etc.).

I would like to know if the libjpeg is compiled into mencoder or do I 
need to get a dll or something for it work?

Thanks in advance

David N.

More information about the MPlayer-users mailing list