[MPlayer-users] nvidia/cvidix "Can't find chip" -- NOVIRUS

Sascha Sommer saschasommer at freenet.de
Sat Jan 31 12:27:11 CET 2004

> > Find out what DEVICE_ID your card has and change the family to
> >
> > Sascha
> >
> Wow, thanks for your quick responses. :)
> My card has a device id of 0281. I looked in your recent patch to
> pci.db, and it corresponds to the following line:
> +d 10de0281 NV28 [GeForce4 Ti 4200 AGP 8x] 0
> ...which in turn looks like it corresponds to line 120 in nvidia_vid.c.
> I changed that to read:
> and recompiled/installed. Still, no luck, though. :(
> I tried xvidix, and still got a green screen. I tried cvidix, and there
> still wasn't any video, with or without -nocolorkey. Then I decided to
> make some logs in case I was doing something boneheaded. When I tried
> xvidix again, instead of a green screen, the video appeared in strange
> diagonal stripes. I wish I could take a screenshot. The stripes have the
> correct luma/chroma from the video, but it's all jumbled to the point of
> being unrecognizable.
> If I use mplayer with -vo xv, xvidix goes back to a green screen. If I
> try cvidix again, xvidix shows diagonal stripes.

So mplayer -vo cvidix -nocolorkey without previous running mplayer -vo xv
gives no image
mplayer -vo cvidix -nocolorkey after running mplayer -vo xv should give
garbled image?
Please always use -nocolorkey -vf scale=640:480 with the vidix drivers for
your test
to avoid problems caused by bad alignment and bad colorkey.
Did you get this garbled image without applying the patch or was there no
image at all
with the same tests?


More information about the MPlayer-users mailing list