[MPlayer-users] DVD support

sirexar sirexar at crazy-horse.net
Mon Jan 19 06:34:39 CET 2004

I have libdvdread and libdvdcss installed, I played a DVD in mplayer 
last night and was very happy.  Today I tried to play an encrypted one 
on Mplayer1.0pre3 and it doesnt work.  So i updated all my libraries and 
tried again.  Same result:

Playing dvd://1.
Reading disc structure, please wait...
There are 27 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
Cache fill:  3.91% (20480 bytes)    LMLM4 Stream Format not found
MPEG-PS file format detected.
VIDEO:  MPEG2  720x480  (aspect 2)  29.970 fps  8000.0 kbps (1000.0 kbyte/s)
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 2.0 (stereo)  48000 Hz  192.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 24000->192000 (192.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.3.1
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
[pl_volnorm] Normalizer plugin in use.
[pl_eq] Equalizer in use.
alsa-init: requested format: 48000 Hz, 2 channels, Signed 16-bit 
alsa-init: 1 soundcard found, using: hw:0,0
alsa9: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little 
AO: [plugin] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 720x540 Planar YV12
xscreensaver_disable: Could not find xscreensaver window.
A:   0.5 V:   0.0 A-V:  0.463 ct:  0.003    1/  1   0%  0%  0.0% 0 0 0%
alsa-uninit: pcm closed
Exiting... (Quit)

So I decided to take a try with ogle and it worked perfectly fine.  
Needless to say i prefer Mplayer and I'm wondering whats going on.

More information about the MPlayer-users mailing list