[MPlayer-users] problems building mplayer 1.0pre3 under Solaris 2.8/gcc

Ziying Sherwin sherwin at nlm.nih.gov
Tue Apr 13 21:31:34 CEST 2004

Dear MPlayer Colleagues,

Enthused by the limited success of a colleague who built mplayer under
Solaris, we tried to build MPlayer 1.0pre3 under our Solaris 2.8
machines using gcc 3.3.

we ran into many problems, summarized below.  If anyone has insights, we'd be
grateful to read them.  Here is what our configure command looked like:

   ./configure \
         --prefix=/depot/package/mplayer_1.0pre3 \
         --datadir=/depot/package/mplayer_1.0pre3/share \
         --confdir=/depot/package/mplayer_1.0pre3/etc \

All the C files under sub-directory libvo, libmpcodecs/vd_lcl.c and
libavcodec/common.h do not include the header file "config.h" properly.
The line should be:

   #include "../config.h"

instead of

   #include "config.h"

After all the above changes, we still get an error message in the end
(which I have broken up on multiple lines for readability):

   gcc -I/depot/include -L/depot/lib -O4  -mcpu=v8 -pipe -ffast-math
      -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
      -Ilibmpdemux -Iloader -Ilibvo -I/depot/package/freetype_2.1.4/vendor/include -I/depot/package/freetype_2.1.4/vendor/include/freetype2
      -o mplayer mplayer.o mp_msg.o cpudetect.o codec-cfg.o spudec.o
      playtree.o playtreeparser.o asxparser.o vobsub.o subreader.o sub_cc.o
      find_sub.o m_config.o m_option.o parser-cfg.o m_struct.o unrarlib.o
      mixer.o parser-mpcmd.o libvo/libvo.a libao2/libao2.a
      libmpcodecs/libmpcodecs.a mp3lib/libMP3.a liba52/liba52.a
      libmpeg2/libmpeg2.a   libaf/libaf.a libmpdemux/libmpdemux.a
      input/libinput.a postproc/libswscale.a osdep/libosdep.a -Llibmpdvdkit2
      -lmpdvdkit libavcodec/libavcodec.a   -lvorbis -logg       -lpng -lz -lz
      -ljpeg     -L/depot/package/freetype_2.1.4/vendor/lib -lfreetype -lz
      -ltermcap  -lsocket -lnsl   -lungif -L/usr/openwin/lib -lXext -lX11
      -lsocket -lnsl      libfaad2/libfaad2.a    -lGL      -L/usr/openwin/lib
      -lXext -lX11 -lsocket -lnsl  -lsocket -lnsl
      -L/depot/package/esound_0.2.8/lib -lesd
      -L/depot/package/audiofile_0.1.7/lib -laudiofile -lm -lresolv -lposix4
      -lnsl -lsocket -laudio -lXt -L/usr/openwin/lib -lXext -lX11 -lsocket
      -lnsl -lposix4 -lkstat  -lpthread -ldl  -liconv -lintl -lm
      Undefined                       first referenced
       symbol                             in file
      mpcodecs_ad_hwac3                   libmpcodecs/libmpcodecs.a(ad.o)
      mpcodecs_ad_liba52                  libmpcodecs/libmpcodecs.a(ad.o)
      mpcodecs_ad_mp3lib                  libmpcodecs/libmpcodecs.a(ad.o)
      mpcodecs_vd_libmpeg2                libmpcodecs/libmpcodecs.a(vd.o)
      ld: fatal: Symbol referencing errors. No output written to mplayer
      collect2: ld returned 1 exit status
      make: *** [mplayer] Error 1

Since it is mentioned that XFree86 packages have to be installed for X11
supoort, are those functions defined in the XFree86? Does anyone have
successful experience building mplayer on Solaris? Is there any workaround?

Mplayer is an impressive piece of work, and it would be lovely to have it

Ziying Sherwin
RPC Rodgers

More information about the MPlayer-users mailing list