[MPlayer-users] Re: Does radeon_vid.so support Radeon 9600XT cards?

Vladimir Mosgalin mosgalin at VM10124.spb.edu
Fri Apr 2 18:41:58 CEST 2004

On Thu, 1 Apr 2004, Sebastian Kaps wrote:

SK>SK> I've tried them all. None of them help :-/
SK>> Well, you should add some parameters to some of them...
SK>I did ;-)
SK>Now here's a funny one:
SK>I just tried "mplayer -vf noformat -vo ... movie.avi". According to the
SK>manpage, this would default to noformat=yv12. The movie played with
SK>distorted colors.
SK>Then I tried "mplayer -vf noformat yv12 -vo ... movie.avi". This is
SK>wrong syntax since it should have been "noformat=yv12". Anyway, mplayer
SK>complains about the missing yv12 file, but now the colors look right.
SK>I tried with the correct syntax "noformat=yv12" -> color distortion.

Really? Ok, what about "-vf noformat nonexistentfile -vo xv realfile"?
What about "-vf noformat -vo xv nonexistentfile realfile"?

Try also -vf swapuv & -vf rgb2bgr=swap. Not that I think it would help
;), and obviously it isn't right way to fix it, but anyway...

SK>> OK, try to describe how colors are distorted one more time. 
SK>Ok, imagine a picture of the sky with the bright sun. The sky looks
SK>normal blueish but the sun, which is supposed to appear bright white, is
SK>red (and I mean "red" like in #FF0000) while the not-so-bright area
SK>around the sun is yellow.
SK>It's like the few brightest shades of "bright white" become completely
SK>different colors, i.e. "bright white" becomes "red", "brighter white"
SK>becomes "yellow" and "yet brighter white" becomes blue.
SK>I've taken a lousy screenshot with my mobile phone's camera. It's
SK>attached to this message (I hope this is allowed...).

That's really strange... It seems more like driver bug to me (well, not
really a bug, but you'll see what I mean). Maybe y, u & v planes are
screwed really well in video memory.

SK>> And show full output of mplayer -v movie.avi (till the playback
SK>> starts).

You forgot -v (never do this in the future - read TFM). But I guess it
isn't needed anymore.

SK>| [radeon] Found chip: Unknown chip
SK>| [radeon] Driver was forced. Was found unknown chip
SK>| [radeon] Assuming it as Radeon1

It looks like your problem is here - driver assumes that you have R1 and
works different - I don't know if it is true or not, but it should be
fixed anyway.

This can be done easily. Send me (or to this list) your "/sbin/lspci -v"
output and the exact name of your card.



More information about the MPlayer-users mailing list