[MPlayer-users] /dev/fb0 no such device

Felix Cuello felix at anubis.qodiga.com
Wed Sep 24 13:09:45 CEST 2003

On Wed, Sep 24, 2003 at 11:40:47AM +1000, Adam Nielsen wrote:
> When you load the module, does your video card switch into graphics mode?  If 

> it stays in text mode the module isn't working, but if it goes into graphics 
> mode you should be able to run "fbset" to see what graphics mode you're 
> running in.  If you can run fbset, then mplayer should work properly.
fbset say something like 640x480-60, then I suppose that framebuffer are
enabled. In fact, when I play a movie [from console] mplayer works fine.

> Also you do realise that using the framebuffer device only works from a 
> console - you can't use it from within X11.  If you want to watch movies from 
Good point :-) [I experienced crashes using framebuffer from X :-))))].

> within X, you need to use an X11 output device, such as -vo xv or -vo x11 
> instead.

I was compiled mplayer with a lot of parameters, but only this
combination was good for me:

/configure --enable-gui --enable-xv --enable-x11 --enable-tdfxfb

With this configure parameters './configure' fails because I don't have
this libraries:


Then I was installed the missing libraries and compiled again and mplayer 
worked!!!. In fact I can run 'mplayer somefile.avi' from X and the movie 
start, without the '-vo' parameter.

Is xlib-dev mandatory to enable xv and x11 support?

> These distros may have loaded all the framebuffer devices automatically, which 
> meant that whichever one worked for your card would've become active.

Thanks a lot for your help, and thanks everyone. 

Now my mplayer are working fine! 



Félix Cuello
felix at qodiga.com
Como soy filósofo, tengo un problema para cada solución.

More information about the MPlayer-users mailing list