[MPlayer-users] status of the rtsp support NOVIRUS

Luca Abeni lucabe72 at email.it
Mon Sep 22 15:10:50 CEST 2003

Hi all,

I am trying to use mplayer + live.com to receive some MP2 or MP4 streams
via rtsp... I tried to connect to the Darwin streaming server for MP4
and to the live.com vobstreamer for MP2 and I obtained the same result:
mplayer displays few frames, and then blocks.

I am still trying to investigate the problem, but it seems that the
mplayer RTP demuxer starts to discard packets because the difference
between audio and video timestamps is too big...

Is this a known issue? Any suggestion on how to debug it?
If someone was able to correctly receive an MP2 via rtsp, can he
describe his setup?

I just configured mplayer with
./configure --enable-live --with-livelibdir=...
and compiled, then I compiled  vobstreamer on a different machine an ran
./vobStreamer ~root/vobcopy-0.5.8/tmp/MONSTERS_INC/VIDEO_TS/VTS_01_1.VOB
Created RTSP server.
Access this stream using the URL:
Beginning streaming...
Beginning to read from

Then I ran mplayer on the client machine:
[luca at passo main]$ ./mplayer -vo x11 rtsp://
MPlayer dev-CVS-030922-10:01-3.2 (C) 2000-2003 MPlayer Team

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville 933.4 MHz
(Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or
Reading config file /home/luca/.mplayer/config
Reading /home/luca/.mplayer/codecs.conf: Can't open
'/home/luca/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: This codecs.conf is too old
and incompatible with this MPlayer release! at line 6
Using built-in default codecs.conf
font: can't open file: /home/luca/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Permission denied (mplayer should be setuid
root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /home/luca/.mplayer/input.conf: No such
file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such
file or directory
Falling back on default (hardcoded) input config

Playing rtsp://
Not a Realmedia rtsp url. Trying standard rtsp protocol.
Connected to server:
Stream not seekable!
Initiated "audio/AC3" RTP subsession
Initiated "video/MPV" RTP subsession
VIDEO:  MPEG2  720x576  (aspect 2)  25.000 fps  4000.0 kbps (500.0
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 5.1 (3f+2r+lfe)  48000 Hz  384.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 48000->192000 (384.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.3.1
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
Checking audio filter chain for 48000Hz/2ch/16bit ->
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int 
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit ->
Starting playback...
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [x11] 720x576 => 768x576 Planar YV12 
SwScaler: using unscaled Planar YV12 -> BGR 16-bit special converter
New_Face failed. Maybe the font path is wrong.  1   0%  0%  0.0% 0 0 0%
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A:   0.4 V:3090.3 A-V:-3089.933 ct:  0.059   22/ 22  22% 47% 480.6% 21 0
The audio pts increases for some time (while the video pts remains 0),
then the video pts jumps to 3090.0 and everything stops...

Sorry, I know that this is not a proper bug report, but I am still
investigating the problem, and I just want to know if anyone else is
having similar problems.

Copy this in your signature, if you think it is important:
                               N O    W A R ! ! !

Email.it, the professional e-mail, gratis per te: http://www.email.it/f

Natsabe.it la più grande erboristeria multimarca online.
Solo prodotti di altissima qualità. 

Clicca qui: http://adv.email.it/cgi-bin/foclick.cgi?mid=1308&d=22-9

More information about the MPlayer-users mailing list